Problem
Compliance Sampler warning Event ID 41596 is added to the Enterprise Vault (EV) server's EV Event Log every hour when Compliance Accelerator (CA) is not present in the environment but Discovery Accelerator (DA) is installed and configured.
The warning states that the EV Storage Service will stop after 6 hours by default if the issue is not resolved; however, no instance of this service stopping has been reported.
Applies to EV 14.5.0.
Error Message
Log Name: Veritas Enterprise Vault
Source: Enterprise Vault
Event ID: 41596
Task Category: Compliance Sampler
Level: Warning
Keywords: Classic
User: N/A
Computer: <EV server name>
Description:
Failed to refresh the Compliance Sampling configuration from the Compliance Accelerator configuration database '<DA configuration database name>'. Compliance Sampling will continue to use its existing configuration for a set period, if available (6 hours by default). After this period Enterprise Vault will stop the Storage service if any attempt is made to archive an item to ensure that no items are precluded from sampling.
Ensure that the database is correctly configured in the Accelerator Manager website and is online and accessible to the Vault Service account.
SQL Instance: <SQL Server name>
Database: <DA configuration database name>
Error: Could not find stored procedure 'spConf_Get_Customer_IRServer_Mapping'.
V-437-41596
Cause
A change in EV 14.5.0 causes the EnterpriseVaultDirectory database's AcceleratorConfigEntry table to be updated when the Enterprise Vault Accelerator Manager Service (EVAMS) is started on the DA server upon DA's installation and configuration. This change added a column named ConfigType with a default value of 2 that is associated with CA. When both CA and DA are present in the EV environment, this table is updated with a row for each configuration database for CA and DA, with the CA row having ConfigType set to 2 and the DA row having ConfigType set to 4.
In rare occurrences, in an EV environment where only DA is installed and configured, the row for DA defaults the ConfigType to 2.
Solution
Contact Veritas Technical Support to implement the resolution to correct the ConfigType value for the DA instance in the AcceleratorConfigEntry table.
There are currently no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. While this issue may be resolved in a future major revision of the software at a later time, it is not currently scheduled for any release. If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.