EmlMsgFile connector is not backing up certain items.

Article: 100056186
Last Published: 2023-05-23
Ratings: 0 0
Product(s): Veritas Alta SaaS Protection

Problem

Specific items are not getting backed up with the EML connector. 

Error Message

Item met connector write policy but preparing the item to be written failed.
Error preparing item for writing.  Full path: 'D:\ToIngest\Announcement.msg'.
Error converting D:\ToIngest\Announcement.eml.TEMP to eml file.
Error in StgOpenStorage: STG_E_FILEALREADYEXISTS

Stack Trace:
   at Redemption.IRDOSession.GetMessageFromMsgFile(String FileName, Boolean CreateNew)
   at HubStor.Connectors.EmlMsgFile.EmlMsgFileConnector.‪‌‪‍‫‪‍‌‌‏‍‍‎‪‫​‪(String , String )

Stack Trace:
   at HubStor.Connectors.EmlMsgFile.EmlMsgFileConnector.‪‌‪‍‫‪‍‌‌‏‍‍‎‪‫​‪(String , String )
   at HubStor.Connectors.EmlMsgFile.EmlMsgFileConnector.prepareItemForWriting(ConnectorLocation location, ConnectorItem item)

Stack Trace:
   at HubStor.Connectors.EmlMsgFile.EmlMsgFileConnector.prepareItemForWriting(ConnectorLocation location, ConnectorItem item)
   at ​‏‎‎​‍‎‏​‎‌​‪‪‎​‍​‍.‎‏‫‫​​‏‎‪‏‏‪‍‫‫‪‏‫(Object[] , IComparable )

Stack Trace:
   at ​‏‎‎​‍‎‏​‎‌​‪‪‎​‍​‍.‎‏‫‫​​‏‎‪‏‏‪‍‫‫‪‏‫(Object[] , IComparable

Cause

This issue can occur if the source file being converted is corrupted. Test opening the source .msg file without Outlook and if it cannot be opened and edited as normal then Alta Saas Protection will not be able to process the item. Sometimes this can happen if the item is exported. 

Solution

Use a good copy of the source item and attempt to process again. 

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