Unregistered domain addresses in Veritas Alta Archiving get disabled after Exchange Online Sync runs
Problem
User accounts with an unregistered domain get disabled after each Exchange Online Sync run in Veritas Alta Archiving.
Error Message
No errors are produced. Only the outcome of the user accounts that have an unregistered domain get disabled, if used in conjunction with the Veritas Alta Archiving Exchange Online Sync.
Cause
During an Exchange Online Sync run, all domains belonging to a customer M365 tenant are first fetched and then validated to determine if they are registered. If there are any unregistered domains in M365 then those accounts in Veritas Alta Archiving will get disabled after that sync completes. This behavior is by design.
This is commonly seen with users that do archiving as the email addresses have an unregistered domain.
Solution
This behavior is as designed.
Please create a Support case if there is a need to create an exception for the unregistered domain so it can be used simultaneously with the Veritas Alta Archiving Exchange Online Sync.