'Backup from Snapshot’, 'Restore' and 'Indexing from Snapshot’ jobs may get held up intermittently for a couple of minutes if Snapshot Manager is located on AWS instance with IMDSv2 enabled.
Problem
NetBackup offers functionality of 'Backup from Snapshot’, 'Restore' and 'Indexing from Snapshot’ for protecting cloud assets. 'Backup from Snapshot’, 'Restore' and 'Indexing from Snapshot’ jobs protecting cloud asset may get held up intermittently for a couple of minutes and this behavior could be of intermittent nature.
Error Message
There is no error message or error code.
Cause
If IMDSv2 is enabled on the NetBackup Snapshot Manager AWS instance, then AWS API while fetching metadata from its endpoint, may get stuck for inordinate amount of time intermittently while fetching IMDSv2 session token.
Solution
Veritas is working with AWS to look into this issue.
As a workaround, one can use IMDSv2 as optional metadata service.
- Check the existing metadata service configured by running the following AWS CLI command:
> aws ec2 describe-instances --instance-id <instance id> --region <region>
Response: Reservations -> Instances -> MetadataOptions -> HttpTokens
- If IMDSv2 metadata service has been enabled on the AWS instance where Snapshot Manager resides, then consider making use of HttpTokens optional.
> aws ec2 modify-instance-metadata-options --instance-id <instance id> --region <region> --http-tokens optional
For more information on the IMDSv2 service, refer to AWS documentation, section Use IMDSv2.
External Link: https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/configuring-instance-metadata-service.html