Enterprise Vault Indexing service terminates due to JVM timeout

Enterprise Vault Indexing service terminates due to JVM timeout

Article: 100054397
Last Published: 2023-03-06
Ratings: 7 1
Product(s): Enterprise Vault

Problem

Enterprise Vault Indexing service terminates due to JVM timeout. This issue applies to EV 14.2 & later versions.

 

Error Message

Event ID: 41312 The Elasticsearch Indexing Engine could not complete all the required startup routines: Failed to start Elasticsearch JVM. Service will be stopped.

V-439-41312

Event ID: 41293 An unexpected error has occurred. |Error Summary: Indexing Service start up error |Error Details: Fatal error in Indexing Service child process EV Indexing Engine Elasticsearch.

V-439-41293

 

Cause

It has been identified that at times the JVM takes more than the desired time (60 seconds) to start, due to this JVM gets timed out.

 

Solution

This issue has been resolved in EV 14.3.1 and later releases with a new configuration setting.  The JVM timeout value is now configurable via the EVIndexingEngineElasticsearch.exe.config file (<EVInstall Directory>\Enterprise Vault) by setting the below key:  

<appSettings>
<add key="JVMStartUpTimeOutInSeconds" value="240"/>
</appSettings>

EV 14.3.1 can be downloaded from here (Veritas Downloads).

Note: It may also be necessary to increase the Maximum child process startup time to allow indexing to start properly. 

  1. Open the Vault Administration Console 
  2. Expand Directory on Server_name > Site_Name > Enterprise Vault Servers
  3. Right-click on the server name and choose Properties 
  4. Go to that Advanced tab and choose Indexing in List settings from: 
  5. Modify Maximum child process startup time to 5 and click OK

 

References

JIRA : CFT-5011

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