問題
SQL バックアップが「最終エラー:1 つ以上の SQL データベース一貫性チェックに失敗しました」で失敗する。
エラーメッセージ
最終エラー: 0xe0008443 - 1 つ以上の SQL データベース一貫性チェックに失敗しました。
最終エラーカテゴリ: リソースエラー
このエラーについて詳しくはリンクを参照してください V-79-57344-33859
エラー:
V-79-57344-65085 - データベースの一貫性がありません。
ジョブログで次のエラーが報告される場合もあります。
DBCC の試行中に、不明または予期しないデータベース エラーが発生しました。
または
V-79-57344-65085 - ファイルにアクセスできないか、メモリまたはディスク領域が不足しているので、データベース "データベース名" を開けません。 詳細については、SQL Server エラー ログを確認してください。
または
V-79-57344-65085 - 現在のセキュリティコンテキストでは、サーバープリンシパルはデータベース "データベース名" にアクセスできません。
または
V-79-57344-65085 - [DBNETLIB][ConnectionRead (recv()).] 一般的なネットワーク エラーです。ネットワークのマニュアルを調べてください。
原因
次のようなさまざまな原因が考えられます。
- バックアップ対象のデータベースがオンラインではないか、アクセスできません。
- Backup Exec サービスアカウントには、SQL データベースにアクセスするための十分な権限がありません。
- 実際のデータベースの一貫性に問題があります。
- データベースはシングル ユーザー モードであり、別のアプリケーションまたは SQL Management Studio で既に開かれています。
解決策
以下のソリューションを確認します。
1. 問題のデータベースがオンラインであることを確認します。データベースがオンラインでない場合は、バックアップのためにオンラインにする必要があります。
2. SQL Management Studio を使用して、問題のデータベースにアクセスできることを確認します。
3. 以下の方法で、Backup Exec サービス アカウントに十分な権限があることを確認します。
a) SQL Management Studio を開きます。
b) インスタンスに接続し、セキュリティ > ログイン を表示します。
c) Backup Exec サービス アカウント (BESA) または SQL バックアップに使用されるアカウントがリストにあることを確認します。
- 見つからない場合は、Backup Exec アカウントまたは SQL バックアップに使用されるアカウントを追加して Sysadmin ロールを付与します。
- 既に存在する場合は、Sysadmin ロールが割り当てられていることを確認します。
d) アカウントのプロパティで [User Mapping] を選択します。
- [Users mapped to this login] の下で、[master] データベースを選択します。
- [Database role membership for: master] で、[db_datareader] と [db_datawriter] を選択します。
4. DBCC コマンドが Backup Exec の外部で機能することを確認します。
Backup Exec の DBCC 利用方法の詳細については、https://www.veritas.com/content/support/en_US/article.100031237 を参照します。
a) SQL Management Studioを起動し、バックアップ対象データベースの含まれるインスタンスに接続します。
b)[新しいクエリ]をクリックします。
c) 問題が発生しているデータベースを選択し、入力画面に以下のコマンドを入力し、[実行]をクリックします。
use DatabaseName
dbcc checkdb
注: DatabaseName は、失敗した SQL ジョブのジョブ ログに表示されるデータベースの名前です。
5. 構成されているユーザー モードを確認します。
a) SQL Management Studioを起動し、バックアップ対象データベースの含まれるインスタンスに接続します。
b) データベースのツリーを展開し、バックアップ対象のデータベースを右クリックして「プロパティ」を開きます。
c) 「オプション」ページの「状態」見出しにある「アクセスの制限」設定が MULTI_USER であることを確認します。
設定が SINGLE_USER の場合、バックアップが失敗する可能性があります。
設定を MULTI_USER に変更すると、セッションが開いていてもバックアップが可能になります。