Unknown UserId found: 'unknown'. Will use 'unknown@user.microsoftteams.app' as email.

Article: 100053007
Last Published: 2022-05-20
Ratings: 2 3
Product(s): Merge1

Problem

When viewing Microsoft Teams chats (messages) collected and imported via Merge1, a sender can be listed as unknown.

Error Message

Enabling logging for the Merge1 Microsoft Teams Importer will generate the below warning:

WARN  SenderParser - Unknown UserId found: 'unknown'. Will use 'unknown@user.microsoftteams.app' as email.

Cause

This issue can occur when the sender of a  Microsoft Teams chat is external to the organization.

Solution

This is expected behavior, however the below workarounds may be desirable. 

  • Contact external users as a guest user. This is due to the fact that the Microsoft API does not allow capturing external users' events through its API's
  • A Filter can be put in place to exclude messages that include address - 'unknown@user.microsoftteams.app' from reaching the target.

Was this content helpful?