Scheduled VMware "Inventory" collection failing 'FileAlreadyExistsException - tags.db' but checkinstall works fine

Article: 100050902
Last Published: 2021-07-19
Ratings: 1 0
Product(s): APTARE IT Analytics

Problem

Scheduled VMware Inventory collection fails with unknown error, because a temporary file 'tags.db' did not get deleted in the last collection.
 

Error Message

Error message in APTARE Portal from Data Collection Details:
Unknown error while trying to capture information for VMWare Server <VCenter-IP>

Check whether the command is executable in your environment. Add the command location to the PATH of logged in user environment.

 
Error message in Data Collector log: VMwareInventoryChildThread.log
ERROR  264 Thread-29:VMwareInventoryChildThread:<VCenter-IP> VMwareCollectorWorkerThread.logUnhandledError:2406 - Caught Exception when collecting and posting VM data.
java.nio.file.FileAlreadyExistsException: <APTARE_HOME>\mbs\tmp\vmware.esx\<VCenter-IP>\VMwareInventoryChildThread.cache\tags\tags.db

 

Cause

The tags.db file should have been deleted in the last collection and it is causing the next scheduled collection for VMware Inventory to fail.
 

Solution

The workaround is to delete the temporary file 'tags.db' from the APTARE Data Collector server and let the scheduled collection run:
<APTARE_HOME>\mbs\tmp\vmware.esx\<VCenter-IP>\VMwareInventoryChildThread.cache\tags\tags.db
 
If we get prompted with message: 'File In Use - The action can't be completed because the file is open in java.exe'.
Please stop the APTARE Agent from services and try to delete again. Stopping the APTARE Agent service may delete the tags.db file automatically. Then start the APTARE Agent an d let the collection run on schedule.
 
This will be fixed in the following APTARE versions that are due to be released the first week of September 2021.
Fix Version: 10.5 P11
Fix Version: 10.6 P4

Was this content helpful?