Exit code:33055 reported for Classification requests that get failed from the Data Insight Web Console
Problem
When running a classification request against a share/file/filer in Data Insight, the Classification request would fail within few minutes
Error Message
The following error code is reported in the vic log
WARNING [ContentFetcher$Fetcher.fetch] Fetch for share <MSU ID> failed with exit code: 33055
AND
INFO: #{27} [ContentFetcher$Fetcher.fetch] Error fetching content for xxx_classifyinput.db (scanner exited with code: 33055)
Cause
This error would occur when there is no communication between the Classification Server and the Data Source to be classified.
For the files to be classified, during the "ContentFetch" job, the Classification server needs to contact the Data Source (Filer) to "fetch" i.e copy the files over to itself into its \DataInsight\data\classification\content folder,
If there is no communication between the Classification Server and the Filer then this Fetch job would fail, eventually causing the entire Classification request to fail.
Solution
Make sure the Classification Server is able to communicate with the Filer for whom the Classification is requested.
The Filer whose content is requested for classification should get pinged from the Classification server and it should be able to copy/fetch files from the Filers over the network.