NetBackup Appliance upgrade fails to 3.3.0.1 or 4.0 during NetBackup upgrade

NetBackup Appliance upgrade fails to 3.3.0.1 or 4.0 during NetBackup upgrade

Article: 100049021
Last Published: 2021-03-23
Ratings: 1 0
Product(s): Appliances, NetBackup

Problem

NetBackup Appliance upgrade fails to 3.3.0.1 or 4.0 during NetBackup upgrade section. The appliance upgrade pre-flight checks are all passed and the AURA checks are passed, but the upgrade can fail during the NetBackup application upgrade part when some add on packages are not uninstalled first.

Error Message

Appliance upgrade patch log will display:

Installing VRTSnbclt ...
Failed to install VRTSnbclt status = 2.
        Check /tmp/install_VRTSnbclt.rpm_trace.111096 for details.
        Aborting ...

ERROR:   Detected a failure running cp_to_client Linux RedHat2.6.32.

Example trace file (install_VRTSnbclt.rpm_trace.111096) will display:

Installing VRTSnbclt ...
Preparing packages...
         file /usr/openv/lib/libntnxahv.so from install of VRTSnbclt-8.3.0.1.x86_64 conflicts with file from package NBAPP_addon_Nutanix-AHV-HMI_Plugin-8.2.0.0.x86_64
         file /usr/openv/lib/libntnxahvST.so from install of VRTSnbclt-8.3.0.1.x86_64 conflicts with file from package NBAPP_addon_Nutanix-AHV-HMI_Plugin-8.2.0.0.x86_64
         file /usr/openv/lib/libpinutanix-ahv.so from install of VRTSnbclt-8.3.0.1.x86_64 conflicts with file from package NBAPP_addon_Nutanix-AHV-HMI_Plugin-8.2.0.0.x86_64

Cause

During the NetBackup portion of the appliance upgrade (Executing 31th command 'install_NB') the Client package (VRTSnbclt) fails because of an Add On package had previously been installed. The NetBackup upgrade documentation states this package must be removed before an upgrade to 8.3/8.3.0.1 and 9.0 (appliance 3.3.0.1 equivalent and 4.0 equivalent) is performed, but it appears the appliance upgrade notes or pre-flight checks do not allow for this scenario, which is why a failure will occur.

  • Add on package: NBAPP_addon_Nutanix-AHV-HMI_Plugin-8.2.0.0.x86_64

Note: The package name for Nutanix above is an example, the same issue maybe seen if other Addon packages, so please consult the NetBackup upgrade documentation for NetBackup and appliances before proceeding further.

Solution

Before an upgrade to appliance 3.3.0.1 or 4.0 is performed, please ensure to remove the Nutanix Addon package. If the package is left and the failure occurs then a rollback will be performed, therefore, before any further upgrade attempts are performed, please remove the Addon package;

CLISH > Manage > Software > Rollback NBAPP_addon_Nutanix-AHV-HMI_Plugin-8.2.0.0.x86_64.rpm

Note: If the rollback in the CLISH does not work then use 'rpm -e <package_name>'.

References

JIRA : APPCFT-7171

Was this content helpful?