「キャンセルの保留」が表示され、アクティブなジョブのキャンセルに時間かかる

Article: 100048962
Last Published: 2025-05-09
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Product(s): Backup Exec

問題

「キャンセルの保留」が表示され、アクティブなジョブのキャンセルに時間かかることがあります。

 

原因

通常、アクティブなブジョブは数分程度でキャンセルできますが、バックアップ動作自体に問題が発生し、応答しないとき、ジョブのキャンセルに時間かかることがあります。

ジョブのキャンセルに要する時間はバックアップ対象リソースによって異なります。キャンセルを実施したジョブは、そのアクティビティがタイムアウトして完全に終了するまで、「キャンセルの保留」が表示されることがあります。

 

ジョブのキャンセル処理に時間かかる理由として、以下が考えられます。

・サードパーティーのプロセス/プログラム/アプリケーションが応答しない場合。この場合、Backup Exec 側でのジョブの終了処理が遅延します。

・バックアッププロセスが原因不明でスタックした場合。この場合は、プロセスのデバッグログを取得した調査が必要になることがあります。

解決策

Backup Exec 本体と Agent 両方を最新バージョンにアップグレードします。それでもこの問題が発生する場合は、調査のためにサポートへお問合せください。

注意:

・以下の操作前に、ジョブを手動でキャンセルしておく必要があります。

・以下の操作時、実行中のすべてのジョブはキャンセルされます。

 

プロセスを強制的に停止する手順:

1. Backup Exec コンソール > 左上のボタン > 構成と設定 > Backup Exec サービス の順番で「Backup Exec Services Manager」を起動します。

2. 「すべてのサービスを再開」をクリックします。(bengine サービスの処理でハングすることがあります。)

3. タスクマネージャーを開き、「詳細」タブをクリックします。

4. OS バージョンによりますが、「すべてのユーザーのプロセスを表示」ボタンがあれば、クリックして有効にします。

5. 「名前」列をクリックし、アルファベット順で並べ替えます。

6. 次の画面にてハイライトしたプロセスを探します。

 ・Pvlsvr.exe (Backup Exec Device & Media Service サービス)

 ・Bengine.exe (Backup Exec Job Engine サービス)

 ・Beremote.exe (Backup Exec Remote Agent for Windows サービス)

7. 上記のサービスを右クリックし、「プロセスツリーの終了」でプロセスを終了します。

8. タスクマネージャーを閉じます。「Backup Exec Services Manager」の画面に戻ります。

9. Backup Exec のすべてのサービスが停止されたことを確認します。

10. 実施した「すべてのサービスを再開」動作より自動的にサービスの開始が続行されます。

こちらの動作完了後、Backup Exec コンソールを起動してハングしたジョブはもう存在しないことを確認します。

キャンセルされたジョブはジョブモニター下部分の「ジョブ履歴」に「ユーザーがRPCサービスを再起動しました。ユーザーの操作は不要です」と表示します。

 

 

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