Important Update: Cohesity Products Knowledge Base Articles
All Cohesity Knowledge Base Articles are now managed via the Cohesity Support Portal: https://support.cohesity.com/s/searchunify. The Knowledge Base articles available here will not reflect the latest information or may no longer be accessible.
問題
Hyper-V 仮想マシンのバックアップジョブが、以下の VSS スナップショットエラーで失敗します。
エラーメッセージ
Backup Exec ジョブログには、次のエラーメッセージが記録されます。
このエラーについて詳しくはリンクを参照してください V-79-40960-38521
仮想マシンのスナップショットを作成できませんでした。Hyper-V ホストでイベントビューアを使用して原因を特定します。仮想マシンが適切に構成されていない場合は、仮想マシンでイベントビューアを使用して原因を特定する必要があることがあります。
重要
この技術情報では、前述のエラーメッセージに加えて、Hyper-V ホストとバックアップされる仮想マシンのイベントログに次のエラーコードが記載されている場合にのみ適用されます。
0x800423F2
Hyper-V ホストに記録される情報:
イベント ID:10172
VSS writers inside virtual machine '<Name of VM>' failed to perform BackupComplete to its shadow copy (VSS snapshot) set: The writer's timeout expired between the Freeze and Thaw events. (0x800423F2). (Virtual machine ID 00AE1346-040D-4563-B23C-1AC6B61713A1)
イベント ID:2
The VSS writer ASR Writer failed with status 9 and writer specific failure code 0x800423F2
原因
この問題は、セキュリティアカウントマネージャー (SAM) がレジストリへの書き込みを保留している場合に、解凍イベント中に VSS でデッドロックが発生したために発生します。
解決策
この問題が発生している Hyper-V ホスト、およびゲスト仮想マシンが Windows Server 2012 / 2012 R2 / 2008R2 である場合、ホットフィックス 2996928 をインストールしてから、仮想マシンのバックアップを実行します。
注:前述の修正プログラムは、Windows 2012 R2 の更新プログラムロールアップ 3013769 の一部です。更新ロールアップへのリンクは KB3013769 です。
注:前述の修正プログラムで問題が解決しない場合、もしくは Windows バージョン 2016 および 2019 の場合は、Backup Exec Hyper-V バックアップを使用したトラブルシューティング 0xa0009679 / V-79-57344-38521 の技術情報を確認してください。