Repair DBReferences operation fails to load HCP partitions.

Article: 100048398
Last Published: 2022-07-20
Ratings: 1 0
Product(s): Enterprise Vault

Problem

Attempting to run EVSVR Repair DBReferences on an HCP partition does not complete. 

Error Message

Review of the EVSVR Log will appear stuck at the following step:

2020-09-10 14:52:45          Step 3: Recreate missing SISPart records in the Fingerprint database

2020-09-10 14:52:45          --------------------------------------------------------------------

2020-09-10 14:52:45 

2020-09-10 14:52:45          Phase 1: Recreate missing SISPart records

2020-09-10 14:52:45 

2020-09-10 15:01:49 

 

A dtrace of EVSVR will show the following:

2482        14:52:45.200         [10780]        (evsvr)        <4572>        EV:H        {CPartitionPropCache::GetProperty:#235} Failed to find Qualified Property Name [Hitachi Content Platform (HCP) Streamer.partitionGUID] in the Property Map. Error: STORAGE_E_NO_FIND_IN_PARTITION_CACHE

2483        14:52:45.200         [10780]        (evsvr)        <4572>        EV:M        Hitachi Content Platform (HCP) Streamer: CStreamerObject::EnumStart IEVContentStreamerCallback::GetProperty returned partitionGUID = '2531FDAF9A57DE4481D989D4853D2D55'

2484        14:52:45.200         [10780]        (evsvr)        <4572>        EV:M        Hitachi Content Platform (HCP) Streamer: POST: m_file_name is /query

 

Cause

This issue can be caused by certain features not being enabled and or permissions not being set on the Hitachi HCP Device. 

Solution

To resolve this issue there are some features and permissions that need to set on the HCP Tenants and NameSpaces. 

  • Launch the Hitachi Content Platform System Management Console
  • Refer to the 'System Management Help'  in the Hamburger icon in the upper right hand corner of the Management Console. 
  • Enable 'Metadata Query Engine (MQE)'  
    • Service=>Search=>Select 'Metadata Query Engine (MQE)' =>Select 'Update Console Settings'

  • Enable Search on the Tenant
    • In System Management Help Administering HCP>Tenant Administration>Modifying a tenant>Modifying Tenant Properties
    • Tenants=>Expand the Tenant=>Select the Settings Tab=>Check the 'Search' box=> Select 'Update Settings'

  • Enable Search on the NameSpace:
    • In System Management Help: Managing a Tenant and it's Namespaces> Managing Search and indexing for an individual namespace> Setting search and indexing options
    • Select 'Tenants'=> Expand the Tenant=> Select the Overview Tab=> Click the URL to the Tenant to open the Tenant Management Console.

  • From the Tenant Management Console=>NameSpaces=>Services=>Select 'Enable Search' and 'Enable Indexing'=>'Update Settings'
  • After enabling search  permissions will need to be added for the admin user of the tenant.
    • From the Tenant Management Console=>Security=>Users=>Expand the User=>Under 'Assign NameSpace Permissions' expand the NameSpace=>Ensure 'Browse, Read, and Search' are selected=>Select the 'Update Settings' button. 

 

At this point the operation can be retried.   

References

JIRA : CFT-3126

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