DLO Agent - "Failed to load configuration settings" error is displayed while launching DLO Agent.

Article: 100048313
Last Published: 2021-06-09
Ratings: 0 0
Product(s): Desktop Laptop Option

Problem

DLO agent fails to load and error "Failed to load configuration settings" is displayed.

Desktop and Laptop Option (DLO) Agent fails to connect to the Media Server with one of the following errors:

V-138-52224-100

V-138-32772-3604

V-139-57364-7

V-139-32772-3633

V-138-52224-990

V-139-52224-1310 - Failed to initialize the network user data folder.

V-138-57364-5 - Failed to initialize the Network User data Folder

V-138-32778-3706

Cause

This above error is generally caused by Database References that do not contain correct entries and/or insufficient right on SQL Database (DLO) to Open, Query, and Write information.

Solution

1.  Confirm that DLO Service account has permissions on DLO database:

  •      Launch SQL Management Studio --> Security --> Logins, go to the properties of the DLO Service account.
  •      Go to -> Server Roles -> Check "sysadmin" role.
  •      Go to -> User Mapping -> Check "Db_owner" for DLO Database.

2.  Verify the Sharing & Security permission for the NUDF folder:

Share Permissions
Administrators (group)      Full Control        
DLO Service account:      Full Control
Everyone:                        Full Control

Security Permissions

Administrators (group)      Full Control
DLO Service account:       Full Control
SYSTEM:                        Full Control
Everyone:                        Read and Execute

3.  Access the Network path (NUDF) Storage Location from the Client Machine. Also, try to create & delete a file in the NUDF (Network User Data Folder) --> User folder.

4.  If the password is changed for the DLO Service account in Active Directory update then update the password in services.msc for --> "Veritas DLO Administration Service", "Mindtree StoreSmart Dedupe service" & "SQL Server(DLO)" service and restart all the services.

5.  Exclude the DLO process and folder from the Anti-virus:

List of Anti-virus exclusions to configure for Desktop and Laptop Option

    6.  On client machine (DLO Agent), open file "C:\ProgramFiles(x86)\Veritas\VeritasDLO\DLO\UACconfig" and verify the values for 'DBServer, DBInstance and Database Name' are correctly updated.

    Also verify if correct values are updated in following registry keys on DLO agent client machine: 

    HKLM\Software\WOW6432Node\Veritas\VeritasDLO\DB

    or 

    HKLM\Software\Veritas\VeritasDLO\DB

    7.  Perform UDL test on DLO client machine to verify DLO DB connectivity: 
    How to perform a quick test connection to the SQL instance

    8.  If the issue seen after DLO server version upgrade, run the below scripts on the DLO Admin Server:

    •      Open the command prompt as Admin on the DLO Admin server
    •      Change directory to "C:\Program Files\Veritas\Veritas DLO\"
    •      Stop 'Veritas DLO Administration Service, Mindtree StoreSmart Dedupe Server and SQL Server (DLO)' services for DLO, and make copy backup of following folders

    "C:\Program Files\Veritas\Veritas DLO\Data" and "C:\Program Files\Veritas\Veritas DLO\Dedupe\Database"

    NOTE: If DLO and Dedupedb files are stored in any other folder/path, please make a copy backup of those folders.

    •      Start 'Veritas DLO Administration Service, Mindtree StoreSmart Dedupe Server and SQL Server (DLO)' services.
    •      Execute following commands commands:

    DLO Intsallpath>osql -E -S %COMPUTERNAME%\DLO -d DLO -i DLODBUpgrade20.sql

    DLO Intsallpath>osql -E -S %COMPUTERNAME%\DLO -d DLO -i DLODBUpgrade30.sql

    DLO Intsallpath>osql -E -S %COMPUTERNAME%\DLO -d DLO -i DLODBUpgrade.sql

    DLO Intsallpath>osql -E -S %COMPUTERNAME%\DLO -d DLO -i DLODBInstallXSP.sql

    Where,

    %COMPUTERNAME% = Name of the server running SQL instance for DLO.

    DLO = Name of the SQL instance of DLO database.

    9.  Upgrade DLO to the latest version: 

    Step By Step guide to download and install Veritas Desktop and Laptop Option

    10.  Rename the .settings folder in the Client Machine by following steps.

    •      Exit DLO Agent.
    •      Stop the "Veritas DLO Desktop Agent Change Journal Reader service"
    •      Go to C:\Users\<UserName>\AppData\Local\Veritas\DLO and rename the ".settings" folder
    •      Start the "Veritas DLO Desktop Agent Change Journal Reader service"
    •      Re-launch the DLO Agent.

    11. For DLO MAC Agent error "Unable to connect to media server. Either you are not connected to the network or the server is not responding. DLO needs to be able to contact the server to perform this action."

    Edit AgentConfiguration.Plist file and update IP address for DLO server instead of server name.

    Provide permissions for user to access the Storage location (NUDF).

    12.             Go to Network tab of MAC agent, add FQDN with DNS IP

    Refer for more info: https://www.veritas.com/support/en_US/doc/DLO_931_AdminGuide

     

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