Failure to create disk volume when configuring MSDP cloud from NetBackup web UI on upgraded HA appliances (nodes)

Article: 100048259
Last Published: 2020-10-05
Ratings: 0 0
Product(s): Appliances

Problem

Failed to create disk volume when configure MSDP cloud via NetBackup Web Console on upgraded HA appliance

Error Message

Cause

After upgrading an appliance high availability (HA) node to version 3.3.0.1 and then configuring MSDP Cloud from the NetBackup web UI, an error message reports a failure to create a disk volume.

Solution

Perform the following tasks to resolve the issue:

  1. Log in to the appliance through the shell menu and run the following command
    Manage > HighAvailability > Status
  2. Record the the HA virtual hostname.
  3. Log in to the appliance as a NetBackup CLI user and run the following command to backup the MSDP configurations:
    nbdevconfig -getconfig -stype PureDisk -storage_server <HA virtual hostname> > puredisk_nbdevconfig.backup
  4. Run the following command to set the MSDP configurations:
    nbdevconfig -setconfig -stype PureDisk -storage_server <HA virtual hostname> -configlist puredisk_nbdevconfig.backup
  5. Run the following command to check if the MSDP Cloud service is enabled in the MSDP registry file:
    pdcfg --check=/msdp/data/dp1/pdvol/etc/pdregistry.cfg --section='Symantec/PureDisk/OpenCloudStorageDaemon'".

    If the output shows "Section "[Symantec/PureDisk/OpenCloudStorageDaemon]" does not exist in the configfile.", continue with the remaining steps. For any other output result, the operation is complete.
  6. Run the following command to enable the MSDP Cloud service in the MSDP registry file:
    pdcfg --write=/msdp/data/dp1/pdvol/etc/pdregistry.cfg --section='Symantec/PureDisk/OpenCloudStorageDaemon' --option=loglevel --value='1'
  7. Run the following command to start all MSDP services:
    pdde start

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