VMware credential validation failed (135) and Login failed (Status -1)

Article: 100046618
Last Published: 2020-07-23
Ratings: 1 0
Product(s): NetBackup

Problem

When trying to change vCenter credential from Any to a specific backup host/media server, validation errors are being received.

 

Error Message

Example popup error messages from the NetBackup Administration Console:

Change Virtual Machine Server - vCenter01.veritas.com
VMware credential validation failed. (Status 135)

Change Virtual Machine Server - vCenter01.veritas.com
VMware credential validation failed. Login failed (Status -1)

 

Cause

For this example, there were compounding (multiple) issues.

  1. Hung processes on the VMware backup host/media server, or full /tmp directory, preventing temporary files from being generated.
  2. The VMware NetBackup account being used for vCenter credentials has been locked out.

Troubleshooting for each item:

  1. On the backup host, run the bpVMutil command to refresh the VM cache, which should generate a temporary file. For this example, it did not generate the temporary file, due to a hung process.
    • Linux/Unix: /usr/openv/netbackup/bin/bpVMutil 0 0 _NONE_
    • Windows: install_path\Veritas\NetBackup/bin/bpVMutil.exe 0 0 _NONE_
  2. On the backup host, run the bpVMutil command to validate credentials, which should generate a temporary file. For this example, this command failed with "Unable to get server credentials", also due to the hung process. After restarting services, the temporary file was being generated but the contents stated "Login failed", and the VMware Administrator determined this was due to the account being locked out.
    • Linux/Unix: /usr/openv/netbackup/bin/bpVMutil 512 _NONE_
    • Windows: install_path\Veritas\NetBackup/bin/bpVMutil.exe 512 _NONE_

 

Solution

Recommend:

  1. Restart NetBackup and PBX services on the backup host/media server.
  2. Engage the Virtualization team to unlock the account used with NetBackup to access the vCenter.

 

Was this content helpful?