Important Update: Cohesity Products Knowledge Base Articles


All Cohesity Knowledge Base Articles are now managed via the Cohesity Support Portal: https://support.cohesity.com/. The Knowledge Base articles available here will not reflect the latest information or may no longer be accessible.

Backup Exec unable to establish a Trust with vCenter with error 'Unable to fetch Certificate'

Article: 100045119
Last Published: 2024-11-18
Ratings: 0 2
Product(s): Backup Exec

Problem

Backup Exec  console was unable to establish a Trust with the remote vCenter server.

 

Error Message

 

Cause

Believed to be due to a mismatch of certificates in use between the servers;

  • The VMware vCenter server was using the default Self-Signed (SHA1) Certificate
  • The Backup Exec server was using a Certificate Authority Issued (SHA256) certificate

 

Solution

Once the Self-Signed (SHA1) certificate on the vCenter server was replaced with a CA issued (SHA256) certificate, the Backup Exec server was able to successfully establish a Trust to the vCenter server.

Another solution is to regenerate the certificate.

 

Note: Restarting Backup Exec services is required after updating vCenter certificate.


Regenerate vSphere 6.x, 7.x, and 8.0 certificates using self-signed VMCA

Configuring CA signed certificates for ESXi hosts

vSphere Authentication

 

Please note that this article references sites not owned or maintained by Veritas and, as such, Veritas is not responsible for the content portrayed on such sites, including any revisions to or deletions of content or third-party software on which this article relies. User is responsible for conducting all necessary due diligence prior to following the instructions described in this article.

 

Was this content helpful?