eDP On-Premise Exchange Collection is denied access even though the Source Account has 'Full Access'
Problem
The Exchange Source Account has 'FullAccess' on a users mailbox and fails to collect with a permissions error: MAPI_E_FAILONEPROVIDER
Error Message
Could not OpenMsgStore for profile: EXCHCOLLECT_e06878464077ba5ddff0ccba9a7daf29 Store:Test.Account@edp.lab Error:MAPI_E_FAILONEPROVIDER
Exception while collecting mailbox 4e6d7900b07841999c39d3c251e42801-Test Account. Error code: 15003, Error Message: OpenMsgStore failed.. Make sure that the source account has full access permission on 4e6d7900b07841999c39d3c251e42801-Test Account.
Cause
The 'FullAccess' permission is Inherited instead of being applied directly to the user's mailbox.
Inherited Permissions Example:
Full Access for the Source Acct: edp\ExchSourceAcct
Solution
Apply 'FullAccess' permissions directly to the mailbox to be collected.
To view current mailbox permissions on a single mailboxget-mailbox -Identity Adam.Coleman@edp.lab | Get-MailboxPermission -user < Insert eDP Exchange Source Account >
If IsInherited is True, the direct 'FullAccess' needs to be applied
To Add 'FullAccess' permission directly (not through inheritance) to a single user mailboxGet-Mailbox -Identity < user email address > | Add-MailboxPermission -User < eDP Exchange Source Account > -AccessRights fullaccess -InheritanceType all
To Add 'FullAccess' permission directly to all user mailboxes
Get-Mailbox -ResultSize unlimited -Filter {(RecipientTypeDetails -eq 'UserMailbox')} | Add-MailboxPermission -User < Insert eDP Exchange Source Account > -AccessRights fullaccess -InheritanceType all -AutoMapping:$false