DLO Remote Administration console either does not connect to the DLO Administration server or does not show all data correctly

Article: 100042850
Last Published: 2025-06-13
Ratings: 0 0
Product(s): Desktop Laptop Option

Problem

The DLO Remote Administration console either does not connect to the main DLO Administration server or does not show all data correctly.

There are no error messages in the console and after a brief period of trying, will 'time out', failing to connect or display the data.

 

Error Message

The DLOConsoleu.log will show the following SQL connnection failure messages:

dloconsoleu.exe, 11092:,  >, adoutil.h( 76 ), Connection error: FFFFFFFF80004005( 0000000000000011 ) : [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.

dloconsoleu.exe, 11092:, E>, adodb.cpp( 622 ), failed opening connection: ADODBError-_com_error: foundationerror=cc000064; comerr=80004005; nativeerror=17; conn=Provider=SQLOLEDB;Initial Catalog=DLO;Integrated Security=SSPI;Net=dbnmpntw;Address=\\<server>\pipe\sql\query;Connect Timeout=20; query=, msg=Unspecified error; src=Microsoft OLE DB Provider for SQL Server, desc=[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.

 

Cause

The Remote Administration Console installation adds the required registry entries for the DLO console, but not for the DLO Database, as there is no local DB installation. This means that connection details are not available if there are problems with the Remote Administration Console connecting fully to the DLO database.

 

Solution

1) On the main DLO Administration server, open Regedit and Export the relevant DLO DB Registry branch and all sub-keys (DBDataFile, DBInstance, DBLogFile, DBName, DBServer, etc)  in that. Depending on which version of DLO you are using and whether the system has been upgraded, the Registry paths will either be  :

          HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\Veritas DLO\DB             

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

 

2) Take that exported Registry file to the DLO Remote Administration server and import the keys into the Registry there, recreating the \DB branch and sub-keys.

3) Reopen the DLO Remote Administration Console and this should now connect and show data correctly.

 

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