Case fails to restore with error java.lang.IllegalStateException: No audio volume requirement to check quotas
Problem
When restoring a Case backup it fails to restore immediately.Error Message
The Case restore job log shows the following error:
10/07/2025 15:45:55 Starting case restore: 0.2.1.3/0.6.33676.280744943/Project Overlord/Project Overlord-20170710144207GMTDT
10/07/2025 15:45:55 Restore case -- checking backup directory Project Overlord-20170710144207GMTDT
10/07/2025 15:45:55 ABR: No audio data to restore: Project Overlord-20170710144207GMTDT
10/07/2025 15:45:56 Case restore failure: 0.2.1.3/0.6.33676.280744943/Project Overlord/Project Overload-20170710144207GMTDT
07/10/2025 15:45:56 Case restore failure: 0.2.1.3/0.6.33676.280744943/Project Overlord/Project Overlord-20170710144207GMTDT
java.lang.IllegalStateException: No audio volume requirement to check quotas
com.teneo.esa.esacase.CaseLicenseAdmin.getDiffAudioVolume(CaseLicenseAdmin.java:350)
com.teneo.esa.esacase.CaseLicenseAdmin.hasAudioQuota(CaseLicenseAdmin.java:280)
com.teneo.esa.esacase.CaseLicenseAdmin.checkQuotas(CaseLicenseAdmin.java:247)
com.teneo.esa.esacase.CaseManagerImpl.restoreLocalCase(CaseManagerImpl.java:2576)
com.teneo.esa.esacase.CaseManagerImpl.restoreBackedUpCase(CaseManagerImpl.java:2219)
com.teneo.esa.esacase.CaseManagerImpl.restoreCase(CaseManagerImpl.java:2204)
com.teneo.esa.esacase.CaseRestoreJobDescriptor$1$1.run(CaseRestoreJobDescriptor.java:148)
com.teneo.esa.jobmanager.JobRunner.executeJob(JobRunner.java:152)
com.teneo.esa.jobmanager.JobRunner.executeJob(JobRunner.java:137)
com.teneo.esa.jobmanager.JobRunner.access$000(JobRunner.java:59)
com.teneo.esa.jobmanager.JobRunner$1.call(JobRunner.java:184) com.teneo.esa.common.ThreadPool.Task.cwRun(Task.java:288)
com.teneo.esa.common.util.CWRunnableImpl.run(CWRunnableImpl.java:46)
com.teneo.esa.common.util.CWThread.run(CWThread.java:88)
Cause
This issue has been seen to occur with Cases created on older eDP versions. (Note: The eDP version where the Case was created is the Case version and is listed on the "All Processing"
page of the User Interface).
One other situation in which this issue is known to occur is when the Case backup is created before any source data has been indexed into the Case.
A Case backup that has been affected by this issue is recognized by the presence of the following two -1
values in the Case backup's casebackup.properties
file:
crawledAudioVolume=-1
crawledAudioMediaVolume=-1
Solution
Workaround
- Identify the location of Case backups.
- Go to System > Support Features and select the Property Browser support feature.
- In Pattern to match, enter the value esa.case.backupDir and click Submit (Figure 1.)
Figure 1.
- Locate the
casebackup.properties
file of the Case backup in question and change the following two values from -1 to 0:
crawledAudioVolume=0
crawledAudioMediaVolume=0 - Save the changes to the
casebackup.properties
file and retry the Case restore.