Please enter search query.
Search <product_name> all support & community content...
Incoming audit/scan events are directed to the C:\DataInsight\data\indexer\err folder of the indexer
Article: 100032441
Last Published: 2023-08-25
Ratings: 1 0
Product(s): Data Insight
Problem
If the index.db is deleted, or otherwise corrupted, incoming audit, or scan, events to the inbox of the indexer cannot be processed. They will be directed to the C:\DataInsight\data\indexer\err (default location) folder on the indexer.Error Message
The log may contain messages indicating that there are files in the C:\DataInsight\data\indexer\err (default location) folder.
In addition to the presence of files in the E:\DataInsight\data\indexer\err (used for this example) folder, run the mxview -a command from C:\Program Files\DataInsight\bin on the indexer.
Missing files will be present as below (Figure 1):
Figure 1
Cause
This can be caused by corruption or deletion of the index.db. This is often seen when the index.db files are deleted to free disk space.Example:
According to the configuration, there should be an index.db at E :\DataInsight\data\indexer\default\1\1, but it cannot be found (Figure 2).
Note: In this example, we are dealing with Matrix Storage Unit (MSU) 1.
Figure 2
In the E:\DataInsight\data\indexer\default\1\1 directory, the following contents are found. Notice that there is no index.db.1115 file, but there are associated files (Figure 3).
Figure 3
Solution
To correct this issue, the database needs to be rebuilt by Data Insight.
Understand that the data that was contained in this index is now unrecoverable. A new index is simply being rebuilt to make Data Insight healthy again.
Please Contact Technical support for help to rebuild the index.