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NetBackup backups are failing with status code 247 even though policy is active

Article: 100032120
Last Published: 2016-03-16
Ratings: 1 1
Product(s): NetBackup

Problem

Backups for a new policy immediately fail with status code 247 (the specified policy is not active) and the Detailed Status from the failed job in the Activity Monitor is blank. 

Attempts to set the policy to inactive then active again, via the Java Admin Console, indicate that the policy is already active.

Error Message

Job error listed in the Activity Monitor:
Status: the specified policy is not active(247)

For the job failing with status 247, unified log context* output via vxlogview shows:
*(-X=context [--ctx], grabs related data into one output/file)

UNIX/Linux: /usr/openv/netbackup/bin/vxlogview -p 51216 -X "jobid=541"
Windows: install_path\Veritas\NetBackup\bin\vxlogview -p 51216 -X "jobid=541"

3/15/2016 14:11:48.737 [Info] V-116-14 CLIENT *NULL*  POLICY TEST  SCHED *NULL*  EXIT STATUS 247 (the specified policy is not active)

nbpem unified logs (OID 116), via vxlogview shows:
3/15/2016 14:11:48.721 [Info] V-116-80 received start immediate backup request for client=*, policy=TEST, schedule=?, stream #=0, client type=MS-Windows (13), parent jobid=-1
3/15/2016 14:11:48.721 V-116-189 [ExtReqTask::run_specificPolicy] Failed to retrieve policy TEST, 247
3/15/2016 14:11:48.721 [PemTask::taskComplete] (ID:0000000000F9B758 CTX:0000000000F9B758) Active subtask count=0(PemTask.cpp:529)
3/15/2016 14:11:48.721 V-116-215 [ExtReqTask::taskCompleted] jobid=-1 submitted to nbjm for processing
3/15/2016 14:11:48.737 [Info] V-116-14 CLIENT *NULL*  POLICY TEST  SCHED *NULL*  EXIT STATUS 247 (the specified policy is not active)



 

Cause

This behavior can occur when the NetBackup master server is running a maintenance release on top of a full NetBackup GA version, but the NetBackup Java Administration Console (GUI) is only running the GA version (has not been patched to match the Master).

Creating a Policy using a mismatched version of the Java Console can produce a corrupt Policy which has a hidden value or has an invalid entry set within the policy . This can prevent the policy from initiating the backup successfully.

Solution

Resolution
It is recommended to upgrade the NetBackup Java Administration Console to the same version/maintenance release as the NetBackup master.
Once upgraded, delete and recreate the problematic Policy using the proper console version.


Workaround
If upgrading the Java Console is not possible, activating the problematic Policy via command line interface (CLI) may correct the issue

Follow these steps:
  1. Run the bpplinfo command to set the policy to an active state
    • bpplinfo <policy_name> -modify -active
  2. Manually initiate the backup for the problematic policy
The backup should initiate, properly show details in the Activity Monitor, and complete successfully.

Note: If the above workaround does not resolve the problem, delete the problematic policy and recreate it using a Java Console which matches the same version/maintenance release as the NetBackup master server - as stated in the resolution above.

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