Backup Exec SQL Service BKUPEXEC instance will not start due to damaged database files.

Article: 100031757
Last Published: 2025-07-03
Ratings: 1 0
Product(s): Backup Exec

Problem

The Backup Exec SQL service BKUPEXEC fails to start which prevents the Backup Exec services from starting.

If the SQL System database files are damaged, symptoms may include:

1. An inability to start SQL
2. Segmentation faults or input/output errors
3. A report generated by the SQL Database Consistency Checker utility (DBCC)

 

Error Message

Application Log Error(s)

Log Name:      Application
Source:        MSSQL$BKUPEXEC
Event ID:      9003
Task Category: (2)
Level:         Error
Keywords:      Classic

Description:
The log scan number (24:362:1) passed to log scan in database 'model' is not valid. This error may indicate data corruption or that the log file (.ldf) does not match the data file (.mdf). If this error occurred during replication, re-create the publication. Otherwise, restore from backup if the problem results in a failure during startup.



Log Name:      Application
Source:        MSSQL$BKUPEXEC
Event ID:      9003
Task Category: (2)
Level:         Error
Keywords:      Classic

Description:
The log scan number (545:240:1) passed to log scan in database 'master' is not valid. This error may indicate data corruption or that the log file (.ldf) does not match the data file (.mdf). If this error occurred during replication, re-create the publication. Otherwise, restore from backup if the problem results in a failure during startup. 



Additionally the following event's may appear in the System Event Log.
Disk corruption or file corruption may have caused the issue with SQL System Database Files.


Log Name:      System
Source:        Service Control Manager
Event ID:      7024
Task Category: (2)
Level:         Error
Keywords:      Classic
The SQL Server (BKUPEXEC) service terminated with service-specific error %%3414.


Log Name:      System
Source:        Service Control Manager
Event ID:      55
Task Category: (2)
Level:         Error
Keywords:      Classic
"The file system structure on the disk is corrupt and unusable.
Please run the chkdsk utility on the volume \Device\HarddiskVolume."

 

Cause

One of the Backup Exec SQL (BKUPEXEC) instance SQL system files is corrupt or damaged.





 

Solution

Review the Application Event log Details for Event ID 9003.

Determine the problem SQL system database file (Master, Model, or Msdb ).




How to replace the corrupt or missing SQL system database and log files with the copies of the SQL system database and log files:


1. Go to the MSSQL Data folder on the Server where SQL is installed (Figure 1)

(Backup Exec 2012 and above)
C:\Program Files (x86)\Microsoft SQL Server\MSSQL10_50.BKUPEXEC\MSSQL\DATA

Figure 1
User-added image




2. With every full backup of a MSSQL Server or instance the following files get created (Figure 2)

Figure 2
User-added image



master$4idr
mastlog$4idr
model$4idr
modellog$4idr
msdbdata$4idr
msdblog$4idr





3. Rename the corrupted database and log files to ".old".
    Note: Only rename the database files reported corrupted in the Applicatoin Event log error.




4. Change or rename the matching $4idr files to the appropriate mdf or ldf files.
    
    Note: Only rename the database files reported corrupted in the Application Event log error.


master$4idr     -->    master.mdf
mastlog$4idr    -->    mastlog.ldf

model$4idr    -->    model.mdf
modellog$4idr    -->    modellog.ldf

msdbdata$4idr    -->    msdbdata.mdf
msdblog$4idr    -->    msdblog.ldf




5. Before starting the SQL SERVER (BKUPEXEC) service remove the "READ-ONLY" attribute from the   database and log files that were just renamed. (Figure 3)

Figure 3

User-added image




6. Start the SQL Server (BKUPEXEC) service. 
7. Start the Backup Exec Services.

 

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