"Unable to get retention categories for selected file servers" appears during the creation of a report with an Enterprise Vault remediation action

Article: 100031549
Last Published: 2026-01-08
Ratings: 0 0
Product(s): Data Insight

Problem

The creation of a report, with an Enterprise Vault remediation action, fails to save because the Enterprise Vault (EV) server fails to provide retention information for the filer.

Error Message

Either disable "Take action on data generated by reports" or Select "Retention Category" and "Post Processing action"

Unable to get retention categories for selected file servers. Please check the configuration.

Cause

Consider the following scenario:
  • The EV (Enterprise Vault) server has been added to Data Insight (DI).
  • DI is able to retrieve the Retention Category names, but fails when requesting retention times.

In this case, the issue may be a difference in the filer host names. DI will use the filer name when requesting information from the EV server for which it is configured. The phrase "selected file servers" could indicate a naming mismatch because EV has the same filer configured with a different name.

For example, the DI server could be configured to use the cluster name of the filer, while the EV server is configured to use a specific filer node name.  

Solution

Add a filer mapping to the EV configuration within DI.

1. From the DI console, open Settings > Data Management.
2. Select Add Filer Mappings.
3. In the listed row, for the filer in question, add the name of the filer that is configured within EV to the Enterprise Vault Filer column.
4. Click Save.

 

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