There was a failure downloading the Integration Dll! Please check the IntegrationUrl BravaXParam.

Article: 100031130
Last Published: 2015-10-15
Ratings: 2 0
Product(s): eDiscovery Platform

Problem

When attempting to install the native viewer using the MSI the following error is generated.

Error Message

There was a failure downloading the Integration Dll! Please check the IntegrationUrl BravaXParam.

 

Cause

The user does not have permission on their local machine to install ActiveX or the MSI.

By default, the MSI installer will install the ActiveX plugin files into directory "C:\Program Files (x86)\IGC\". When the plugin is first used, write access is required to this directory in order to initialize the contents. If a user is the first person to load the plugin, but does not have write permissions to this directory then they will see this error.

 

Solution

There are three possible solutions for this issue.

Solution 1:
If the plugin is to be used by non-admin Windows users, ensure that the users have sufficient access to the directory where the files are installed by the MSI installer. Because the plugin files are initialized the first time the plugin is used, the first user to load the plugin requires the following permissions to the installation directory (Figure 1).

Figure 1.


The MSI installer allows the user to specify an install directory other than the default directory of "C:\Program Files (x86)\IGC". One way to avoid this error is to install the files to a new directory away from "C:\Program Files (x86)\", for example "C:\NativeViewPlugin\IGC\". Alternatively, if there will only be one user on the client machine using the plugin, the files can be installed to that user's profile directory, for example "C:\Users\johnsmith\IGC\".

Note: If it is necessary to automate the installation, the MSI installer can be run silently from the command-line as follows:

msiexec /I "Clearwell Native Viewer (ActiveX) 7.1SR1.msi" /qn INSTALLDIR="C:\NativeViewPlugin\IGC\" /l*vx msi.log

 

Solution 2:
Use Clearwell Native view once, while logged into the client's machine as an Administrator user. This will initialize the plugin files in the installation directory. Non-admin users should then also be able to use the plugin.
 

Solution 3:
Disable UAC on the client's machine using the following instructions from Microsoft:
https://windows.microsoft.com/en-GB/windows-vista/Turn-User-Account-Control-on-or-off

 


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