Problem
eDisconvery Platform (eDP) users can encounter an issue where the user interface displays the "Message referred by a URN could not be retrieved." error message.
Error Message
For versions V7x and greater, the error message is: [#10025] Message referred by a URN could not be retrieved.
For versions below V7x the error message is: [#10024] Message referred by a URN could not be retrieved.
From server log with timeout issue:2024-09-20 11:46:25,316 ERROR [resource.documents.DocumentsResource] (https-jsse-nio2-443-exec-19-332810746:[]) CaseName:\\{*}EM-215887-REDACTED-REDACTED\\{*} UserName:[332810746-410081034] 10025 Message referred by a URN could not be retrieved.
2024-09-20 11:46:25,316 ERROR [resource.documents.DocumentsResource] (https-jsse-nio2-443-exec-25-332810746:[]) CaseName:[EM-215887-REDACTED-REDACTED] UserName:[332810746-410081034] [71001] [71001] 41047 Unable to retrieve email content: Retrieval timed out
2024-09-20 11:46:26,572 DEBUG [util.security.RequestProcessorUtil] (https-jsse-nio2-443-exec-22-332810746:[]) CaseName:[EM-215887-REDACTED-REDACTED] UserName:[332810746-410081034] srrId is: [2]
Cause
The error described in the screen shots generally means that eDiscovery can no longer access the source. This can happen when:
- Source data has been moved from the original location
- Networking issue
- Permissions
- Timeouts when trying to retrieve information/data from the source location. If this is the issue, it could look like the issue comes or goes and/or for different items, making the issue appear to be intermittent and random..
Solution
To locate where the sources are expected to be found, hover over the envelope; this will popup the source location.
1. Ensure the service accounts used for the ESA Application Service and all Crawler/Retriever services on the eDiscovery appliance have read/write access to the source.
a. Login to the eDiscovery appliance as each of these service accounts.
b. Make sure the source can be accessed with read and write permissions.
2. If the source is not at the original location because it has been replaced, deleted, or moved, find the originally indexed source data and put that back into the proper source location. If the data cannot be put in the original location and must reside in a different location, then the eDP support feature tool called Source Locator Modifier would need to be used to change the location paths.
3. Use the eDP support features tool called Property Browser to increase the timeout for property esa.queryengine.contentretrieval.timeout.ms to a higher value. The default is 30000. A value of 60000 would double the default timeout to 60 seconds. This change requires an eDP services restart using the CW Utility option 3 and option 4 to take effect.
NOTES:
1. After a source has been indexed, the source should not be moved. Do not move the source or change the sources in any way.
2. If moving a source is required use the support feature "Source Locator Modifier"
3. Do not use the same source for another case. Use a different copy of the source for each case.