CentOS 5.2 x86 and x64 are now supported as a client in NetBackup 6.5.2. This document covers a few known issues when using Centos 5.2 as a client with NetBackup 6.5.2.

CentOS 5.2 x86 and x64 are now supported as a client in NetBackup 6.5.2. This document covers a few known issues when using Centos 5.2 as a client with NetBackup 6.5.2.

Article: 100030487
Last Published: 2009-01-12
Ratings: 0 0
Product(s): NetBackup

Problem

CentOS 5.2 x86 and x64 are now supported as a client in NetBackup 6.5.2. This document covers a few known issues when using Centos 5.2 as a client with NetBackup 6.5.2.

Solution

Issue 1
In the default CentOS 5.2 installation,SELinux may prevent /usr/openv/netbackup/bin/bpcd from loading /usr/openv/lib/libnbmangle.so.  

This can result in theclient reporting a Status 24 (socket read error) and/or the followingmessage(s):
bpcd:error while loading shared libraries: /usr/openv/lib/libnbmangle.so: cannotrestore segment prot after reloc: Permission denied

SELinuxis preventing /usr/openv/netbackup/bin/bpcd from loading/usr/openv/lib/libnbmangle.so which requires textrelocation.

In order to start bpcd and address this, performthe following steps:

1)  Edit /etc/selinux/config. Modify "SELINUX=enabled" to"SELINUX=disabled".

2)  Run following commandsas root to enabled proper access to the necessary libraries:
   chcon-t textrel_shlib_t /usr/openv/lib/libnbmangle.so
   chcon-t textrel_shlib_t /usr/openv/lib/libvxPBXCommon.so
   chcon-t textrel_shlib_t /usr/openv/lib/libvxPBX.so
   chcon-t textrel_shlib_t /usr/openv/lib/libvxPBXVxSS.so
   chcon-t textrel_shlib_t /usr/openv/lib/libvxVxSSIOP.so
   chcon-t textrel_shlib_t /usr/openv/lib/libnbservice.so

3)  Restart the system andclient operations should be restored.


Issue 2
The Java NB Console may fail to launchwith error "java.lang.UnsatisfiedLinkError:/usr/openv/java/jre/lib/i386/libawt.so: libXp.so .6: cannot open shared objectfile: No such file ordirectory".        

LibXp.so.6 may not beinstalled by default.  If not present, the NetBackup Console will fail tolaunch. Either xorg-x11-deprecated-libs-6.8.1-12.i386.rpm or libXp-1.0.0-11.fc9.i386.rpm is needed before NBU is installed on thisplatform.  Both of these packages contain the library ofLibXp.so.6.

The rpm command can be used to install the neededlibraries:

rpm-i libXp-1.0.0-8.1.el5.i386.rpm



Issue 3
The rsh-server package maynot be installed by default.  If not, Rsh-server must be installedseparately. Rsh is the default method utilized for NetBackup for remote clientinstallation.
If a remote install is attempted and rsh is not installed, thefollowing messages will be seen:

<client_name>...
Client<client_name> -- Linux hardware running RedHat2.6
InstallingNetBackup software on <client_name>
<client_name>:Connection refused
Client<client_name> is not responding.
<client_name>install failed


The rpm command can be used to install theneeded libraries:

rpm -irsh-server-0.17-38.el5.i386.rpm




Was this content helpful?