Backup Exec Device and Media Service fails to start after Backup Exec installation with the error "The Backup Exec Device and Media Service could not start because the database recovery has failed"
Problem
After a reinstallation, upgrade, or SQL database location change of Backup Exec (BE), the Backup Exec Device and Media Service fails to start.
Error Message
The Backup Exec Device and Media Service reports the following error:
"The Backup Exec Device and Media Service could not start because the database recovery has failed. Refer to the database recovery log for details."
The Backup Exec Database Recovery log* reports the following error:
"Error connecting to master database: hr = 0x80040e4d
OS ERROR: 0x80040e4d (-2147217843)
Status of database BEDB is unknown"
* By default, the dbrecover log is located here:
C:\Program Files\Veritas\Backup Exec\Logs\dbrecover.log
UMI Code: V-379-58068
Cause
Case A:
This issue can occur if the Backup Exec Service Account (BESA) is not able to connect to the SQL instance that hosts the Backup Exec Database (BEDatabase). This could occur due to insufficient permission for BESA.
Case B:
This can also happen if the name of the media server has been changed, and the BEDatabase still points to old server name.
Solution
- Verify that the logon account used has administrator rights to the Windows server that the SQL instance is installed on.
- The media server must have access to the SQL installation.
- The credentials stored in the Backup Exec logon account used for backing up and restoring SQL must have been granted the System Administrator role on the SQL instance.
- For additional information on configuring permissions for BESA please refer to the Related Documents section.
Case B:
Check the registry value, and correct if required, at these locations in the registry on the BE Media Server:
HKLM > SOFTWARE > Veritas > Backup Exec for Windows Servers > BEDatabase
HKLM>SOFTWARE>Veritas>Backup Exec for Windows Servers>ADAMM>Database Instance Name