Event 41293 Indexing Service start up error HRESULT 0x80004015

Article: 100027036
Last Published: 2020-09-16
Ratings: 3 1
Product(s): Enterprise Vault

Problem

Enterprise Vault (EV) Indexing Service fails to start. Event 41293 logged stating "The class is configured to run as a security id different from the caller"

Error Message

Event ID: 41293
Task Category: Index Admin Service
Level: Error
Description: An unexpected error has occurred.

Error Summary: Indexing Service start up error
Error Details: The class is configured to run as a security id different from the caller (Exception from HRESULT: 0x80004015)
Reference: ServiceBaseEx::Run
Stack Trace:    at System.Runtime.InteropServices.RegistrationServices.RegisterTypeForComClientsExNative(Type t, RegistrationClassContext clsContext, RegistrationConnectionType flags)
   at Symantec.EnterpriseVault.Indexing.Admin.StateManager.RegisterForDCOMClient()
   at KVS.EnterpriseVault.Common.ServiceBaseEx.ContinueOrAbortStartup(Action action)
   at Symantec.EnterpriseVault.Indexing.Admin.IndexAdminService.OnPerformStartup(Boolean HotRestart)
   at KVS.EnterpriseVault.Common.ServiceBaseEx.Run()
V-437-41293

Cause

Affected Scenario's:

1. It has been observed that after changing the password of Vault Service Account (VSA) user, Indexing Service fails to start.
2. If the GPO applied to the Vault Service Account (VSA) user restricts the Log on as a Service and/or Log on as a batch job rights then Indexing Service fails to start.

Solution

This issue can be resolved by re-entering the password of Vault Service Account (VSA) in Directory properties in Vault Admin console. 

After re-entering the password of Vault Service Account, it updates the password in Enterprise Vault Services properties, DCOM applications properties and updates the required rights in the Security Policy. In case GPO restrictions are in place for VSA user then re-entering VSA password might not work for long term. Make sure the GPO allows the VSA user required rights in Security Policy applied. Refer to the Cause section for required Security policy rights.

To resolve the issue, perform following steps on affected Enterprise Vault (EV) Server:

1. Login to EV Server using Vault Service Account credentials and Open Vault Admin Console.
2. Right click on the Enterprise Vault Directory on <EVServerName> and select Properties.
3. Click on the Service Account tab.
4. Re-enter the correct service account password and click Apply.
5. Click OK to save the changes.
6. And then Restart the Enterprise Vault Admin Service from Services snap-in.

 

NOTE: If the EV server is clustered move the EV resources to the node where services are failing then re-enter the VSA credentials.

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