Event 41293, 40966 - Indexing service start up error: Missing metadata file 

Article: 100025882
Last Published: 2020-09-16
Ratings: 0 0
Product(s): Enterprise Vault

Problem

In a clustered Enterprise Vault (EV) environment, the Indexing service fails to start, generating errors with Events 41293 and 40966, with an error stating Missing Metadata File

Error Message

Event ID: 40966
Description: A program fault has raised an exception.
Exception: Missing metadata directory \\<CLUSTER_VIRTUAL_NAME_HERE>\H$\indexmetadata">\\<CLUSTER_VIRTUAL_NAME_HERE>\H$\indexmetadata.
Create this directory and manually copy content of the previous metadata directory to a new location.
Failure to do this will cause the indexing service to stop.
Diagnostic:
Type: Symantec.EnterpriseVault.Indexing.Admin.ConfigureWebSiteException
Reference: Error while trying to update index metadata locations in Directory DB.
Command Line: "D:\Program Files (x86)\Enterprise Vault\EVIndexAdminService.exe" -EntryID:<EVIndexAdminService_ID_HERE>
Application Domain: EVIndexAdminService.exe
Process Id: <PID_HERE>
Thread Id: <THREAD_ID_HERE>
Stack Trace:    at Symantec.EnterpriseVault.Indexing.Admin.IndexingEngineMonitor.CheckMetadata(String EVIndexingPath, String MetadataPath, Boolean CopyMetadata)
   at Symantec.EnterpriseVault.Indexing.Admin.IndexingEngineMonitor.UpdateMetaDataLocation()

V-437-40966
 

Event ID: 41293
Description: An unexpected error has occurred.
Error Summary: Indexing Service start up error
Error Details: Missing metadata directory \\<CLUSTER_VIRTUAL_NAME_HERE>\H$\indexmetadata">\\<CLUSTER_VIRTUAL_NAME_HERE>\H$\indexmetadata.
Create this directory and manually copy content of the previous metadata directory to a new location.
Failure to do this will cause the indexing service to stop.
Reference: ServiceBaseEx::Run
Stack Trace:    at Symantec.EnterpriseVault.Indexing.Admin.IndexingEngineMonitor.CheckMetadata(String EVIndexingPath, String MetadataPath, Boolean CopyMetadata)
   at Symantec.EnterpriseVault.Indexing.Admin.IndexingEngineMonitor.UpdateMetaDataLocation()
   at Symantec.EnterpriseVault.Indexing.Admin.IndexingEngineMonitor.UpdateIndexingEngineConfigurationFile()
   at KVS.EnterpriseVault.Common.ServiceBaseEx.ContinueOrAbortStartup(Action action)
   at Symantec.EnterpriseVault.Indexing.Admin.IndexAdminService.OnPerformStartup(Boolean HotRestart)
   at KVS.EnterpriseVault.Common.ServiceBaseEx.Run()

V-437-41293

Cause

The Index metadata location specified for the clustered EV servers contains the <CLUSTER_VIRTUAL_NAME> and an Admin Share name.  The servers in the cluster were not allowing EV to access the share.

Note: This can also occur on non-clustered environments

Solution

  • Specify the Index metadata location using the locally attached drive cluster resource.
  • Restart the EV services.
     

Note: For non-clustered servers, copy the content of C:\Program Files (x86)\Enterprise Vault\EVIndexing\data\indexmetadata to the folder specified in the properties of the Indexing Service or make the Indexing Service point to its default location.

 

Applies To

Veritas Cluster (VCS)
 

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