Jobs are queued with status "Limit has been reached for resource ."

Article: 100025154
Last Published: 2025-04-30
Ratings: 0 0
Product(s): NetBackup

Problem

Jobs are queued with status "Limit has been reached for resource <storage unit>."

Error Message

Limit has been reached for resource <storage unit>.

Cause

The above message is an indication that the concurrent write drives as defined in the storage unit properties has been reached.

However, if this message is observed when there are fewer drives active than that defined in the storage unit configuration, then it is an indication of a stuck resource.

Solution

Review the settings for concurrent write drives:

  • Determine how many drives are actually in use for read and write. 
  • If there is a discrepancy, then "nbrbutil -dump" may be used to determine if there are orphaned resources.

If down time can be arranged, the following procedure may be used to reset resource broker allocations at a time when there are no active jobs of any type.

Run the commands listed below from the following location:

  • Linux: /usr/openv/netbackup/bin/admincmd
  • Windows: <installpath>\netbackup\bin\admincmd
  1. On the primary server, suspend scheduling: nbpemreq -suspend_scheduling
  2. Reset resource broker allocations: nbrbutil -resetall
  3. Recycle services and resume scheduling: nbpemreq -resume_scheduling

Note: Running nbrbutil -resetall while there are active jobs can result in corruption.

If only one storage unit is experiencing the issue, then use the following procedure:

  1. On the primary server, suspend scheduling: nbpemreq -suspend_scheduling
  2. Reset resource broker allocations for the storage unit media server: nbrbutil -resetMediaServer <media server name>
    • This will abort any currently running jobs on that media server.
  3. Resume scheduling: nbpemreq -resume_scheduling
 

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