Attempting to enable or disable a Discovery Accelerator Case for Analytics fails due to unfinished or non-existent processes.

Article: 100023445
Last Published: 2023-08-01
Ratings: 0 0
Product(s): Enterprise Vault

Problem

Attempting to enable or disable a Discovery Accelerator (DA) Case for Analytics fails due to unfinished or non-existent processes.

 

Error Message

Event ID 503:

- APP Analytics - Add Items Task with TransactionId AA Failed. Exception: Symantec.Accelerator.Analytics.DataAccess.DataAccessException ---> System.Data.SqlClient.SqlException: Invalid object name 'tblIntAnalysedItems_BB'.
- APP Analytics - Add Items Task with TransactionId CC Failed. Exception: Symantec.Accelerator.Analytics.DataAccess.DataAccessException ---> System.Data.SqlClient.SqlException: Invalid object name 'tblIntAnalysedItems_DD'.

Event ID 493:

- APP Analytics - Could not start RuleEngineJob. View error log for details. Exception:

Event ID 519:

- APP Analytics - AnalyticsConversationAnalyserTask.exe (PID = XXXX) with TransactionId AA failed to read items to process, terminating. Exception: Symantec.Accelerator.Analytics.DataAccess.DataAccessException ---> System.Data.SqlClient.SqlException: Invalid object name 'tblIntAnalysedItems_BB'.
- APP Analytics - AnalyticsConversationAnalyserTask.exe (PID = YYYY) with TransactionId CC failed to read items to process, terminating. Exception: Symantec.Accelerator.Analytics.DataAccess.DataAccessException ---> System.Data.SqlClient.SqlException: Invalid object name 'tblIntAnalysedItems_DD'.

 

Cause

 

The DA configuration database contains tables that associate Analytics tasks that need to be performed for DA Cases that have been enabled for Analytics. When the DA databases are moved improperly or some communications break-down occurs while Analytics enabled Cases are being deleted, the status of certain active Analytics jobs can become stuck or disappear and will no longer proceed to the next step without manual intervention. In addition, interactions between Analytics enabled cases in multiple (i.e., 2 or more) DA Customers on separate DA Servers but sharing the same DA Configuration database can cause Analytics processing to become hung, which, in turn, may affect DA's ability to enable or disable Analytics.

Two workarounds exist to allow DA cases to regain proper Analytics functionality: Workaround 1 is to manually complete any Analytics disabling or enabling processing, Workaround 2 requires replacing the DA Configuration database. Please contact technical support for assistance in implementing the workaround steps.

 

 

Solution

Additional actions may be needed, as follows:

1. Log onto the DA server with an administrative account, such as the Vault Service Account (VSA).
2. Open in a plain text editor, such as Notepad, the file AnalyticsServerApp.exe.config, located in the DA installation folder.
3. Locate the section terminator </appSettings>. Immediately above this terminator line, insert the following lines:

        <add key="AutoPauseAnalyticsCaseWhoseTasksAreLoopingInFailure" value="true"/>
        <add key="LookForAnalyticsCasesToAutoPauseDurationSeconds" value ="45"/>
        <add key="NumberOfFailedTaskCountDefiningContinuousFailure" value="5"/>

3. Save and close the file.
4. Restart the Enterprise Vault Accelerator Manager Service (EVAMS).

 

 

References

Etrack : 2966474

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