In Veritas Cluster Server, the MountV resource faults during online

Article: 100022923
Last Published: 2020-11-20
Ratings: 0 0
Product(s): InfoScale & Storage Foundation

Problem

When a failover or online for a SG is attempted in Veritas Cluster Server, the MountV resource faults during online.

 

Error Message

The following errors is reported in the MountV_A.log

VCS ERROR V-16-10051-9026 MountV:ServiceGroupName-MountV:online:Filesystem at I:\ is not clean [10:105]

 
The OS level, Windows System Event log may report below event with source as NTFS
 
Event Type:Error
Event Source:NTFS
Event ID: 55
Description:
The file system structure on disk is corrupt and unusable. Please run the chkdsk utility on the volume "Drive_letter
 

Cause

The file system has the dirty bit flag set. The "Dirty Bit" is set by the file system itself only if it detects a problem.
 
This can be verified by running the command " fsutil dirty bit query <drive letter>
 
Eg: To check if Volume I: is indeed dirty, the command would be " fsutil dirty query I:"
 

Solution


Option 1:   By defautl, AutoFSClean is set to True. Attempt to online MountV resource and it will prompt the file system to initiate a ChkDsk /x
 
Chkdsk /X:  command parameter runs Chkdsk /F and forces a volume dismount to close open file handles on non-system volumes so it can be checked immediately. This eliminates the need of a potential reboot in order to perform the Chkdsk and repair the volume


Option 2:  Disable the MountV resource in VCS and manually assign a drive letter to the volume from VEA and run a chkdsk for that volume. 

Once chkdsk completes, enable the resource in VEA and probe it, to allow online the MountV resource for that in VCS. 

Warning:  ChkDsk should not be ran on a database volume for Exchange or SQL application without first consulting with your Administrator or Microsoft; due to possible data loss. The ChkDsk operation may cause possible data loss when it runs and corrects/fixes any issues on the File System.

 
Note:
There are many other causes for this error and there may be issues with the Windows File System. If running Chkdsk does not solve this issue please consult Microsoft for solving File System issues on the affected volume. 
 

 

Was this content helpful?