The Vault Service Account temp directory contains many ExchangePerflog*.dat files and is filling up the drive.

Article: 100018616
Last Published: 2020-05-26
Ratings: 4 0
Product(s): Enterprise Vault

Problem

The Vault Service Account (VSA) temp directory contains many ExchangePerflog*.dat files and is filling up the drive.

Cause

The ExchangePerflog*.dat files are created and used by Outlook 2003 for sending RPC performance data to Exchange. There is one file for each profile + security context. Performance records that are to be sent to the server are staged in and out of this file to minimize the amount of data that is kept in memory at any given time.
When using Enterprise Vault (EV) and, after the temporary MAPI profile is deleted, it leaves an orphaned ExchangePerflog*.dat behind, which is not used anymore as its associated MAPI profile no longer exists. 

Solution

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
 

 Add the following registry keys to delete these types of files.
  
Go to Start | Run on the EV server, type regedit and click OK.

  1. Navigate the registry key:
    32bit server: HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\AdminService
    64bit server: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\KVS\Enterprise Vault\AdminService

     
  2. Right-click AdminService key and choose New | String Value.
     
  3. Enter the name DelFileTypes
     
  4. Double-click on DelFileTypes and enter a list of file types separated by a semi-colon.

    For example:​
    ExchangePerf*.dat;EV$*.*;*.tmp;*.dat
     
  5. Right-click AdminService key and choose New | DWORD Value.
     
  6. Enter the name DelFilesOlderThanHours
    Note: Default value is 1 for every hour. 
  7. Double-click DelFilesOlderThanHours and enter a decimal value for hours.
    Note:  If the value of DelFilesOlderThanHours is set to zero, all matching files will be deleted immediately, as long as they are not read-only, are not directories, and are not in use. 
     
  8. Restart the Enterprise Vault Admin Service for the changes to take effect.
  9. Matched files will be automatically deleted every hour, on the hour.

More information on these entries can be found in the Registry_Values.pdf file within Enterprise Vault Documentation located here.

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