The Java Runtime Environment (JRE) used by NetBackup, OpsCenter and related products are not susceptible to Java Applet or Web Start vulnerabilities

The Java Runtime Environment (JRE) used by NetBackup, OpsCenter and related products are not susceptible to Java Applet or Web Start vulnerabilities

Article: 100018063
Last Published: 2015-01-20
Ratings: 2 4
Product(s): NetBackup

Problem

The Java Runtime Environment (JRE) used by NetBackup, OpsCenter and related products do not allow Java Applets or Web Start to run and are not susceptible to Java Applet or Web Start vulnerabilities.

Solution

The Java Runtime Environment (JRE) is used by the Veritas products listed in this article. The JRE implementation used by these products does not use Applets or Web Start to run. As a result, they are not affected by Applet and Web Start security issues.

The following Veritas products are covered in this article:
  • NetBackup 7.x and 8.x along with their respective release updates, maintenance or feature packs use the JRE for the NetBackup Java Administration console.
  • NetBackup OpsCenter 7.x and 8.x along with its respective release updates uses the JRE.
  • PureDisk Remote Office Edition uses JRE for the Web interface in the PureDisk 6.2, 6.5 and 6.6 releases along with their respective hotfixes and release updates. Previous releases of PureDisk do not use the JRE.
The above mentioned products are not vulnerable to JRE Applet or Web Start problems for the following reasons:
  • These products' byte code bases are local to the system.
  • None of these products runs in an Applet or Web Start context as an application accessed by the user's web browser, nor do they run from an Applet or Web Start viewer.
  • None of these products downloads or otherwise receives Java code to be executed from an unknown source.

Was this content helpful?