Problem
The Enterprise Vault (EV) Journaling task fails to process the journal mailbox and Event 2270 logged on Enterprise Vault (EV) server.
Event 2270 logged persistently stating an item from J3 queue has been retrieved but the retry count exceeds the maximum retry limit.
Error Message
Event logs on EV Server shows:
Source: Enterprise Vault
Event ID: 2270
Task Category: Journal Task
Description: A queued operation exceeded the retry count and has been discarded
Exchange Journaling Task for ExchSVR
Retrieved a [MsgID_ArchiveMailboxEx3 (91)] MSMQ message on queue [EVJRNLSVR\Private$\Enterprise Vault Exchange Journaling Task for ExchSVR 140218102334 J3], but it's retry count [4] exceeds the maximum retry limit [3].
V-437-2270
Dtrace Information:
To validate if this is the issue, a Dtrace is needed, please perform the following steps on the Enterprise Vault (EV) server while re-creating the issue.
For more information about Veritas Enterprise Vault’s Dtrace Utility, please see 100038975
Dtrace the JournalTask process for no less than 5 minutes while re-creating the issue.
Open the log file created and search for either of the following the strings:
(JournalTask) <12168> EV:L :CArchivingAgent::IsEligibleForArchive(/O=ExchORG/OU=EXCHANGE ADMINISTRATIVE GROUP (AdminGroup)/CN=RECIPIENTS/CN=JOURNAL_MBX01) |The message titled: <Subject of affected email message> is eligible for archive |
(JournalTask) <12168> EV:M {CJournalPart::MakeJournalPartMsg:#1129} Considering Message [<Subject of affected email message>]
(JournalTask) <12168> EV:M {CJournalPart::MakeJournalPartMsg:#1210} Is a E2007 Journal Message? [True]
(JournalTask) <12168> EV:L {CJournalPart::MakeJournalPartMsg:#1223} Opening The Message
(JournalTask) <12168> EV:H {CJournalPart::MakeJournalPartMsg} HRXEX fn trace : Error [0x80040119], [.\JournalPart.cpp, lines {1109,1226}, built Jan 9 10:22:02 2013].
(JournalTask) <12168> EV:M {CArchivingAgent::isEligibleForArchive:#4758} An error occured hence this message will be ignored.UserMailbox=[/O=ExchORG/OU=EXCHANGE ADMINISTRATIVE GROUP (AdminGroup)/CN=RECIPIENTS/CN=JOURNAL_MBX01] MsgTitle= [<Subject of affected email message>] Hr=[0x80040119]
(JournalTask) <12168> EV:M :CArchivingAgent::IsEligibleForArchive() |Exiting routine |
(JournalTask) <12168> EV:H {CArchivingAgent::ProcessInvalidJournalMessage} HRXEX fn trace : Error [0x80040119], [.\ArchivingAgent.cpp, lines {25521,25532,25533,25547}, built Jan 9 10:22:02 2013].
(JournalTask) <12168> EV:M CArchivingAgent::ProcessInvalidJournalMessage - Com Result [0x80040119]
(JournalTask) <12168> EV:M {CArchivingAgent::processMessages:#5106} Could not scan [user mailbox] [/O=ExchORG/OU=EXCHANGE ADMINISTRATIVE GROUP (AdminGroup)/CN=RECIPIENTS/CN=JOURNAL_MBX01]. This problem is commonly fixed on the next scan. Cannot list messages: [0x80040119] [(null)]
(JournalTask) <12168> EV:L :CArchivingAgent::ProcessFolders() |Exiting routine |
Cause
A corrupt email message in Journal Mailbox.
Solution
This issue can be resolved by locating and moving corrupt email message from Journal mailbox to other location.
1. First, configure Journal Mailbox Outlook profile.
2. Open the Journal Mailbox using the Outlook client.
3. Locate the affected email message in the Journal Mailbox using the 'Subject' found in Dtrace log.
4. Move the affected email message to any other location or a PST file.
5. Restart the Enterprise Vault (EV) Journaling task associated with the affected Journal Mailbox.