Active Directory Synchronization failure 'Incorrect integer value'

Article: 100011956
Last Published: 2025-06-12
Ratings: 0 1
Product(s): eDiscovery Platform

Problem

Active Directory synchronization fails with the error below.

Error

02/18/2014 09:06:46 Starting directory synchronization task
02/18/2014 09:06:46 Waiting for participant sync to complete.
02/18/2014 09:06:51 Found 1 domains to synchronize
02/18/2014 09:06:51 Starting Employee Synchronization
02/18/2014 09:06:51 Updated domain list
02/18/2014 09:06:51 Started crawl for domains domain.com,
02/18/2014 09:07:43 Completed crawl for domains domain.com,
02/18/2014 09:07:43 Merging crawled employees and attributes with database
02/18/2014 09:07:53 Merge: Joined existing tables
02/18/2014 09:08:00 Merge: Loaded Deleted File
02/18/2014 09:08:00 Read input data for first merge pass
02/18/2014 09:08:03 Merged: 10000 employees
02/18/2014 09:08:04 Merged: 20000 employees
02/18/2014 09:08:04 Beginning commit of the merged employees
02/18/2014 09:08:10 Exception in merging employees from directory to database: Commit of updated employee data to database failed - Incorrect integer value: 'xxxxxx' for column 'StartDate' at row 160
02/18/2014 09:08:10 Exception in merging employees from directory to database: Commit of updated employee data to database failed - Incorrect integer value: 'xxxxxx' for column 'StartDate' at row 160
com.symc.cm.exception.CMServiceException: Commit of updated employee data to database failed - Incorrect integer value: 'xxxxxx' for column 'StartDate' at row 160

Cause

Manual entries to the Employee List contain an unsupported comma in the email address.  Microsoft Exchange does not allow for commas within an email address.  The comma in the email address is being mistaken as a field delimiter causing all following data to shift one cell to the left.

Solution

Manually remove the offending comma from all Email Address entries.

  1. Log into the eDiscovery Platform application.
  2. Under All Cases, open the Employee List 
  3. In the Filter List, select E-Mail Address | Contains | ,
  4. Edit the email address of the offending user accounts. (see Figure 1)

Figure 1

Veritas Technologies LLC has acknowledged that the above-mentioned issue is present in the current version(s) listed under the Product(s) Section of this article. Veritas Technologies LLC is committed to product quality and satisfied customers.
 
This issue is currently under investigation by Veritas Technologies LLC. Pending the outcome of the investigation, this issue may be resolved by way of a patch or hotfix in current or future revisions of the software. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.  For information on how to contact Veritas Sales, please see https://www.veritas.com.
 
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

References

JIRA : CFT-7304 JIRA : ESA-35450 JIRA : CFT-6747

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