Event 41293, 40966, 41312 Indexing Service start up error: Child process timeout

Article: 100010750
Last Published: 2020-09-16
Ratings: 0 0
Product(s): Enterprise Vault

Problem

Enterprise Vault (EV) Indexing Service fails to start. Event 41293 logged stating, Index Admin child process EVIndexVolumeProcessor failed to start within timeout period.
Event 40966 logged for IndexVolumeProcessor stating, there is already a listener on IP endpoint.

Error Message

Event ID: 41293
Task Category: Index Admin Service
Level: Error
Description: An unexpected error has occurred.
Error Summary: Indexing Service start up error Error Details: Index Admin child process EVIndexVolumesProcessor failed to start within the timeout period.

V-437-41293

Event ID: 40966
Task Category: Index Volumes Processor
Level: Error
Description: A program fault has raised an exception.
Exception: There is already a listener on IP endpoint 0.0.0.0:8000.
Make sure that you are not trying to use this endpoint multiple times in your application and that there are no other applications listening on this endpoint.

V-437-40966
 
Event ID: 41312
Task Category: Index Volumes Processor
Level: Error
Description: The Index Volume Processor could not complete all the required startup routines.
Exception: There is already a listener on IP endpoint 0.0.0.0:8000.
Make sure that you are not trying to use this endpoint multiple times in your application and that there are no other applications listening on this endpoint.

V-437-41312
 

Cause

The IndexVolumeProcessor process has stopped due to another application listening on the port 8000.

Solution

There are 3 solutions that can be applied:

Solution 1:

  1. Login to affected EV server using Vault Service Account (VSA) credentials.
  2. Go to Command Prompt.
  3. Type command: netstat -noa |find "X" (X being the port number specified in the event log). For Ex. netstat -noa |find "8000" .
  4. If some another process is listening on this port, there will be detail on the screen and at the far right number showing the PID (Process ID)
  5. Open Task Manager to the Details tab.
  6. On the toolbar click on View and click on select column.
  7. Check the box for PID and click on OK.
  8. Now find the PID in the list of processes.
  9. End task that process and start the EVIndexingService from the service console.
  10. Start the other process again which will now utilize any other port by net.tcp.

 


Solution 2:

Performing a NETSTAT -abno | more command should list the name of the all the processes and the PIDs currently running on the Enterprise Vault Server.

If changing the port of the conflicting application is not possible, the port of the EVIndexVolumesProcessor.exe process can be changed. 

  1. Login to affected EV server using VSA credentials.
  2. Go to EV Installation directory and search for EVIndexVolumesProcessor.exe.config
  3. Take backup of this file
  4. Edit the file and look for this line :  <endpoint address="net.tcp://localhost:8000/EnterpriseVault/IndexVolumesProcessor
  5. Change the port to one that is not in use, .i.e. 8001.
  6. Save the file
  7. Start the Index Admin Service  

 


Solution 3:

Ensure that there are enough TCP ports available on the EV server in order to avoid further port conflicts. 

Run the following command to find out how many are currently available:
netsh int ipv4 show dynamicport tcp

If there aren't enough ports available then increase the value:
netsh int ipv4 dynamicport tcp start=1500 num=63000

Was this content helpful?