Case Backup Errors Configured Backup Directory Path "caseBackups" Must Be Absolute When Sharing The Directory
Problem
Case backups fail due to an invalid backup directory path.
Error Message
com.teneo.esa.esacase.CaseManagerException: [#201009] Configured backup directory path "caseBackups" must be absolute when sharing the directory
Cause
In a clustered environment, either Distributed Architecture or Legacy, it is best practice to configure a single, shared destination directory for case backups. To avoid multiple copies of the same backup from appearing on the All Cases or All Processing tabs, the property esa.case.backupDir is set to true to eliminate the duplicates.
When the esa.case.sharedBackupDir property is set to true
, then esa.case.backupDir cannot be set to a relative or mapped path (like the default "caseBackups" or G:\CaseBackup).
Solution
To resolve this issue, set esa.case.backupDir to an absolute path.
- Log into to the eDiscovery application with System Manager credentials
- Go to System > Support Features
- Choose a support feature: Property Browser in the drop-down.
- Under "Name of property to change", enter set esa.case.backupDir
- Under "New value (leave blank to remove)", enter absolute (UNC) path to the backup location
- Check mark "Confirm change. Are you sure?*"
- Click on Submit
An example absolute path is \\<networklocation>\backupdir
All nodes in the cluster must have access to the same esa.case.backupDir location.