NetBackup Catalog Backup DR file is not emailed when master server is installed on 52x0 appliances

Article: 100007214
Last Published: 2020-04-08
Ratings: 0 0
Product(s): Appliances

Problem

NetBackup Catalog backup should send email with the DR file if configured correctly.

The problem here is that the hot catalog backup completes successfully; however, the DR file is never emailed.

Error Message

From the bpdbm log:

14:02:32.177 [24428] <16> db_DR_send_report: failed to execute "/usr/openv/netbackup/bin/mail_dr_info.sh" "email@website" "NetBackup Catalog Backup successful on host host_name status 0" "/usr/openv/netbackup/db/mail/master _server_name_machinetime" "/path/to/file/CATALOG_machinetime_INCR" (9)
14:02:32.177 [24428] <16> generate_and_send_dr_mail: Could not send DR report

Cause

The problem is with /opt/NBUAppliance/scripts/nbapp_common.pm script.

This script calls a function (encode_base64) that was not included at the top of the script.

Solution

Check the script /opt/NBUAppliance/scripts/nbapp_common.pm, and find out whether it is missing the following line:

use MIME::Base64;

If the above line is missing from the script, please contact Veritas Technical Support to get the fix, related Etrack number is 2617244. 

Please note that Veritas does not advise to edit the script under any circumstances.

If the appliance is running version 2.0.2 or higher, please consult 100027327

If the above line exists in the script, there can be other problems, please see 100027327 for the details.

 

Applies To

NetBackup Master server installed on 5220 and 5220 appliances version 2.0 and 2.0.1

 

References

Etrack : 2617244

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