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Unable to open Java Console - error stating "An unknown error has occurred during interface initialization"

Article: 100005860
Last Published: 2012-01-25
Ratings: 1 1
Product(s): NetBackup

Problem

When opening Java Console on master server, after authenticating user login and peer-information, an error is displayed: "An unknown error has occurred during interface initialization. Please see the log file for details."

Error Message

Error from Java Console:

An unknown error has occurred during interface initialization.  Please see the log file for details.

From the bpjava-msvc log:

<16> command_LOGON_TO_MSERVER: putenv(BPJAVA_MASTER_IPC_STRING=) failed
<16> isVxssActive: authentication determination failed, assume none required: (193) VxSS authentication is requested but not allowed
<16> poll_listen: can't find file descriptor in polling table.

Error from admin log:

<16> listerrors: db_begin() failed: cannot connect on socket
 bperror: cannot connect on socket
<2> bperror: EXIT status = 25

Cause

The Primary Server tries to get Master Server, Media Server(s), and Client(s) configuration information, by running the bpgetconfig (/usr/openv/netbackup/bin/admincmd) command in the background and it fails there, as it cannot be executed.

In checking the bpgetconfig binary file, it was found to be corrupted, showing as an empty (0 bytes) file.

Solution

Workaround: Replace the binary from a known good NetBackup (NB) Server (Primary/Master or Media).

  • Find another NB Server running the same OS and NB version.
  • Locate the bpgetconfig binary file in the /usr/openv/netbackup/bin/admincmd/ directory.
  • Copy the good binary and replace the corrupted binary on the Primary/Master Server.
  • From the same path on the Primary/Master server, run the following command:
    • bprdreq -rereadconfig
  • Then, reopen the Java Administration Console.

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