A NetBackup job may record a message in the debug logs; WRN - will not cleanup 'temp' directory, debug level(s) are too high

Article: 100004254
Last Published: 2011-03-30
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

During a client backup, a WRN message may appear in the client bpbkar log file.

WRN - will not cleanup 'temp' directory, debug level(s) are too high

 

Error Message

Example from bpbkar log.

\install_path\NetBackup\logs\bpbkar\mmddyy.log

 

4:48:44.736 PM: [4104.852] <8> tar_backup_tfi::cleanupTemp: WRN - will not cleanup 'temp' directory, debug level(s) are too high

Cause

This is by design, the WRN message is present with elevated debug levels set on the client.

When troubleshooting a NetBackup client a standard practice is to increase debug levels for diagnostic logging. In some situations it's necessary to examine the temporary files created on the client. When the client is in a debug or troubleshooting mode, the temporary files created during client operations (backup) may remain on the client system until manually deleted.

Note: In time the temporary files can accumulate and occupy large quantities of disk space.

If left unchecked temporary files can completely fill the hard drive.

*Best practice is to remove all debug levels during standard client operation.

Solution

To remove temporary files created during debug/troubleshooting mode:

1. Set to zero (0) all debug levels on the affected client.

  • Open the Backup Archive and Restore console.
  • Go to the NetBackup Client Properties.
  • Open the Troubleshooting tab.
  • Set all client debug levels to zero (0).
  • Debug settings include:

General
Verbose
TCP
Flush
Database

Note: A client restart is not required.

Note: Reducing debug levels will not delete any existing files.

2. Manually delete all files in the temporary directory for example:

C:\Program Files\Veritas\NetBackup\Temp
 

With no debug levels set, any new temporary files created during NetBackup backup should be deleted at the conclusion of the backup.

Best Practice: A periodic review of the client to remove temporary files is recommended.


Applies To

Windows 2003 SP2 Client.

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