Backup Exec Agent for Windows installation halts with an unexpected error: the service cannot be started, either because it is disabled or because it has no enabled devices, associated with it. (Exception from HRESULT: 0x80070422)

Article: 100000709
Last Published: 2023-11-07
Ratings: 0 2
Product(s): Backup Exec

Problem


During push installation of Backup Exec Agent for Windows Systems, the following error is observed :

"WMI is not accessible or disabled or may be blocked by the firewall"

During local installation of Backup Exec Agent for Windows Systems, the following error is observed :

"The install failed with an unexpected error: the service cannot be started, either because it is disabled or because it has no enabled devices, associated with it. (Exception from HRESULT: 0x80070422)".
 

 
The following is observed in the Install log of Backup Exec Agent for Windows Systems.

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The install failed with an unexpected error: the service cannot be started, either because it is disabled or because it has no enabled devices, associated with it. (Exception from HRESULT: 0x80070422)
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If the Install is being Run from a network share, copying media locally and retrying the install may resolve this issue.
 
Installation failed with error -532459699. GetLastError= :0
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Error Message

The install failed with an unexpected error: the service cannot be started, either because it is disabled or because it has no enabled devices, associated with it. (Exception from HRESULT: 0x80070422)

Cause


The WMI service on the target machine is disabled/not running or the user account used to install the remote agent on the target machine doesn't have enough privileges to access WMI components.
 


 
What is WMI ?

           WMI comes installed on all of Microsoft's UI based operating systems. Windows Management Instrumentation is a core Windows management technology; WMI can be used to manage both local and remote computers. WMI provides a consistent approach to carrying out management tasks with programming or scripting languages. For example :
 
  • Start a process on a remote computer.
  • Schedule a process to run at specific times on specific days.
  • Reboot a computer remotely.
  • Get a list of applications installed on a local or remote computer.
  • Query the Windows event logs on a local or remote computer.

Solution

Details:

One of the following solutions can be used to resolve this issue.

Solution 1 :

Verify that the Windows Management Instrumentation service is set to 'Automatic' startup type and is started. If not, than set the service to Automatic startup type from Windows Services console and start the service.

Solution 2 :

Enable remote WMI requests:

1. On the target server, go to Administrative Tools > Computer management.
2. Expand 'Services and Applications',
3. Right Click for Properties on 'WMI Control'.
4. Select the Security tab.
5. Click on Security button.
6. Add the account that is used during the installation of the Backup Exec Remote agent for Windows Systems.
7. Check Remote Enable for the user/group that will be requesting WMI data.

Solution 3:

If the account used to install Remote Agent on the target server is NOT an administrator on the target server, a non-administrator will need to be allowed to interact with DCOM: 

  • To grant DCOM remote launch and activation permissions for a user or group

  • To grant DCOM remote access permissions

    Check this Microsoft KB Article for more details <https://msdn.microsoft.com/en-us/library/aa393266(VS.85).aspx>

Solution 4:

Make sure all users (including non-administrators) are able to query/read WMI data on the local computer.
For reading WMI data on a remote server, a connection needs to be made from the Media Server to the remote machine. If the target server is running Windows Firewall, then remote WMI requests are required to be allowed through. This can only be done at the command prompt.

Run the following commands on the target computer if it has Windows firewall enabled:

netsh advfirewall firewall set rule group="windows management instrumentation (wmi)" new enable=yes

netsh advfirewall firewall set rule group="remote administration" new enable=yes

NOTE: If the result of the second command is "No rules match the specified criteria", run the following two commands:

netsh firewall set service remoteadmin enable

netsh advfirewall firewall set rule group="remote administration" new enable=yes

 

 

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