Description of Tape Alerts and code definitions

Article: 100000622
Last Published: 2020-03-25
Ratings: 3 1
Product(s): NetBackup & Alta Data Protection

Problem

Description of Tape Alerts and code definitions

 

Error Message

The "errors" file may also contain specific Tape Alert information:

Unix/Linux: /usr/openv/netbackup/db/media/errors
Windows: install_path\veritas\netbackup\db\media\errors

TapeAlert is a standard for devices to report diagnostic messages to the controlling application. A "No TapeAlert Messages" response is a good thing. Here's the list of codes and definitions as it exists today.
(from the ANSI T10 Specifications):

tapealert_codes = {
0x01: 'Having problems reading (slowing down)',
0x02: 'Having problems writing (losing capacity)',
0x03: 'Uncorrectable read/write error',
0x04: 'Media Performance Degraded, Data Is At Risk',
0x05: 'Read Failure',
0x06: 'Write Failure',
0x07: 'Media has reached the end of its useful life',
0x08: 'Cartridge not data grade',
0x09: 'Cartridge write protected',
0x0A: 'Initiator is preventing media removal',
0x0B: 'Cleaning media found instead of data media',
0x0C: 'Cartridge contains data in an unsupported format',
0x0D: 'Recoverable mechanical cartridge failure (broken tape?)',
0x0E: 'Unrecoverable mechanical cartridge failure (broken tape?)',
0x0F: 'Failure of cartridge memory chip',

0x10: 'Forced eject of media',
0x11: 'Read only media loaded',
0x12: 'Tape directory corrupted on load',
0x13: 'Media nearing end of life',
0x14: 'Tape drive needs cleaning NOW',
0x15: 'Tape drive needs to be cleaned soon',
0x16: 'Cleaning cartridge used up',
0x17: 'Invalid cleaning cartidge used',
0x18: 'Retension requested',
0x19: 'Dual port interface failed',
0x1A: 'Cooling fan in drive has failed',
0x1B: 'Power supply failure in drive',
0x1C: 'Power consumption outside specified range',
0x1D: 'Preventative maintenance needed on drive',
0x1E: 'Hardware A: Tape drive has a problem not read/write related',
0x1F: 'Hardware B: Tape drive has a problem not read/write related',

0x20: 'Problem with SCSI interface between tape drive and initiator',
0x21: 'The current operation has failed. Eject and reload media',
0x22: 'Attempt to download new firmware failed',
0x23: 'Drive humidity outside operational range',
0x24: 'Drive temperature outside operational range',
0x25: 'Drive voltage outside operational range',
0x26: 'Failure of drive predicted soon',
0x27: 'Diagnostics required',

# 0x28 to 0x2E are obsolete, but some vendors still have them listed.

0x28: 'Loader Hardware A: Changer having problems communicating with tape drive',
0x29: 'Loader Stray Tape: Stray tape left in drive from prior error',
0x2A: 'Loader Hardware B: Autoloader mechanism has a fault',
0x2B: 'Loader Door: Loader door is open, please close it',

# 0x2F to 0x31 are reserved

0x32: 'Media statistics lost',
0x33: 'Tape directory invalid at unload (reread all to rebuild)',
0x34: 'Tape system area write failure',
0x35: 'Tape system area read failure',
0x36: 'Start of data not found',
0x37: 'Media could not be loaded/threaded',
0x38: 'Unrecoverable unload failed',
0x39: 'Automation interface failure',
0x3A: 'Firmware failure',

# 0x3B to 0x40 are reserved
}

 

Cause

A "tape alert" message is a critical, warning, or informational alert that occurs due to a tape drive or robotic library hardware event. These "tape alert" messages are stored on the tape drive or robotic library. Applications like NetBackup query the tape device or robotic library for these "tape alert" messages and display the "tape alerts" to the user. "Tape alert" messages are reported in the NetBackup bptm log, which will show in job detailed status if the VERBOSE entry is added to the Volume Manager configuration file (vm.conf). The tape alert technology detects and logs hardware and media errors.

 

Solution

It is important to remember that while NetBackup displays these "tape alerts," the alerts occur due to a tape drive or robotic library hardware event. Check the Operating System logs on Unix/Linux, or the Device Manager and Event Viewer on Windows for any hardware related errors.

Please contact the Original Equipment Manufacturer (OEM) for support with any errors found.

 

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