Image cleanup job is partially successful and "media open error (83)" is seen.

Article: 100000604
Last Published: 2014-09-29
Ratings: 1 1
Product(s): NetBackup & Alta Data Protection

Problem

Image cleanup job is partially successful, and "media open error (83)" is seen.

Error Message

Detailed status for the job shows "media open error(83)"

Cause

Backups were written to Disk Storage units, the media servers still exist but the path to the storage unit does not.
Images still exist in the images database that reference the disk area.

Job Details info:
14/03/2010 21:03:11 - Info nbdelete(pid=xxxx) deleting expired images. Media Server: media1 Media: Z:\Backup
14/03/2010 21:03:11 - started process bpdm (yyyy)
14/03/2010 21:03:11 - Critical bpdm(pid=yyyy) sts_get_lsu_prop_byname on LSU Z:\Backup failed: 2060013 no more entries
14/03/2010 21:03:11 - Critical bpdm(pid=yyyy) Invalid storage device: Z:\Backup no more entries
14/03/2010 21:03:11 - Critical bpdm(pid=yyyy) failure to open disk at path Z:\Backup: plug-in reports error 2060013 no more entries
14/03/2010 21:03:11 - Error bpdm(pid=yyyy) volume Z:\Backup does not exist or is not available.
media open error(83)

This means that a media server called, media1, wrote a backup to Z:\Backup but that folder was deleted before the backup expired. The image cleanup job could not find the folder to clean up.

Solution

1. On server, media1, temporarily create the missing path e.g. Z:\Backup. There is no need to recreate the storage unit itself.
2. Open the NetBackup Console and go to NetBackup Mgmt --> Catalog 

  • Set Action = Duplicate
  • Set Date range to include earliest likely date of problem backups.
  • Set Disk Type = Basic Disk
  • Media server = media1
  • Path = Z:\Backup
  • Run Search Now

If any Backup IDs are returned right click on them and select Expire

3. On the master server start a command prompt and change to the directory:

Windows:  <installpath>\netbackup\bin\admincmd  
Unix:   /usr/openv/netbackup/bin/admincmd

run

  • ./nbdelete -allvolumes -force 
  • ./bpimage -cleanup -allclients

4. Check the Activity Monitor, for an Image Cleanup job.   This should complete with a status 0.
5. Remove the temporary directory created in #1.

 

 

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