問題
System Recovery 18 Service Pack 3 およびそれ以降のバージョンのインストール時、バージョンのアップグレード、Service Pack のアップデート時、または、アンインストール時、「インストールの初期化中」などで処理が途中で止まり完了しない。
インストール、アップグレード、アンインストール時にこの事象が発生した場合は、VproObj.dll が表示した状態で停止します。(図1)
アップデート時にこの事象が発生した場合は、残り時間 0 秒で停止します。(図2)
また、いずれの場合も、キャンセルボタンを押しても、キャンセルができません。
エラー
図1 - System Recovery Service Pack 3 およびそれ以降のバージョンのインストール時
図2 - パッチファイルによるアップデート時
原因
マシンのネットワーク設定にて IPv4 の DNS サーバーが未設定のときに dll ファイルの登録処理中、応答が停止することにより発生します。もし IPv4 の DNS サーバーが設定済みであっても、ネットワークケーブルが接続されていないときは同様の問題が発生します。
解決策
この問題は、Veritas System Recovery 23.3 で解決されています。
回避策
図1または図2の状態が発生した場合は、キャンセルボタンを押した後、図3のように SYSTEM ユーザーで、メモリ使用量の少ない msiexec.exe を右クリックして、[タスクの終了] を選択します。これにより、処理がロールバックして、キャンセルが可能になります。
図3
キャンセルが完了してから、ネットワーク設定にて、DNSサーバーを 127.0.0.1 に設定してから、再度、インストールまたはアップデートを実行します。