System Recovery: VSS の一般的なエラーとエラーの回避方法

記事: 100036813
最終公開日: 2023-09-20
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製品: System Recovery

問題

次の VSS スナップショットエラーで、バックアップジョブに失敗します。

  • VSS スナップショットエラー。選択した Microsoft VSS (ボリュームシャドウコピーサービス) スナップショットテクノロジによって返されました: "予期しないプロバイダエラー"。  すべてのプロバイダサービスが有効で開始できることを確認してください。詳しくは Windows のイベントビューアを確認してください。
    VSS スナップショットに関する他のエラーが表示される場合があります。VSS エラーコードの一覧 (英語) を次の URL で参照できます。
    http://msdn.microsoft.com/en-us/library/windows/desktop/aa381603(v=vs.85).aspx
  • エラー E4F3000E: ボリュームシャドーコピーサービスの使用中にスナップショットに失敗しました。 アプリケーションイベントログで VSS エラーを確認してください。エラーコード: EndCreateSnapshotSet (-2147212300)。

 UMI: V-281-3215-6071

エラーメッセージ

  • 選択した Microsoft ボリュームシャドーコピーサービス (VSS) スナップショットプロバイダが「予期しないプロバイダエラー」を返しました。  すべてのプロバイダサービスが有効で、起動できることを確認します。詳しくは Windows イベントビューアを確認してください。
    VSS スナップショットに関連する他のエラーを参照してください。VSS エラーコードのリストは次の URL で入手できます
    (http://msdn.microsoft.com/en-us/library/windows/desktop/aa381603 (v=vs.85).aspx)
  • エラー E4F3000E: ボリュームシャドーコピーサービスの使用中にスナップショットの作成に失敗しました。アプリケーションイベントログで VSS エラーを確認してください。エラーコード: EndCreateSnapshotSet (-2147212300) です。

原因

VSS スナップショットエラーは、さまざまな原因で発生する可能性があります。たとえば、Microsoft VSS がオペレーティングシステムに正しく登録されていなかったり、ボリュームのシャドーコピーの関連付けが破損していたり、設定が不適切だったりすることが原因として挙げられます。また、その他の環境要因も原因として考えられます。

解決方法

次の操作を実行します。

  • コンピュータを再ブートします。再ブートだけで VSS フレームワークがリセットされることがあります。 
  • 管理者権限でコマンドプロンプトを開き、「VSSADMIN LIST WRITERS」と入力します。ライターが安定していることを確認します。
  • Microsoft VSS サービスが「無効」になっていないことを確認します。手動で VSS を起動します。エラーが発生せずに起動することを確認します。 
  • すべての VSS ライターが安定している状態にあることを確認します。管理者権限でコマンドプロンプトを開きます。プロンプトで、「VSSADMIN LIST WRITERS」と入力します。すべてのライターが安定していることを確認します。 
  • サービスコンソールから、各種のアプリケーション VSS ライターサービスをエラーなしで開始できることを確認します。
  • vssadmin Resize ShadowStorage コマンドを使用して、VSS シャドウストレージのサイズを変更します。このコマンドは管理者として実行する必要があります。以下に例をいくつか示します。
    • vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=900MB
    • vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=UNBOUNDED
    • vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=20%
  • システムで予約済みのパーティションと Windows 回復機能用のパーティションが存在する場合は、これらのパーティション用の VSS シャドウストレージのサイズを変更します。例を次に示します。
    vssadmin resize ShadowStorage /For=\\?\Volume{a309c667-5a3f-4718-9d4b-e128827866eb} /On=\\?\Volume{a309c667-5a3f-4718-9d4b-e128827866eb} /MaxSize=UNBOUNDED.
    mountvol コマンドを実行して、ボリュームの GUID を確認できます。非表示のボリュームにドライブ文字を割り当て、前述のコマンドを使用してシャドウストレージのサイズを変更する方法もあります。
  • 次のコマンドを使用して、既存のすべてのシャドウコピーを削除します。
    vssadmin delete shadows /all
  • 管理者権限でコマンドプロンプトを開き、SFC /SCANNOW を実行して、破損した Windows システムファイルをスキャンして復元します。
  • 最新の VSS hotfix をインストールすることで、多くの問題を解決できます。

 

参照

UMI : V-281-3215-6071

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