Backup job may get stuck in cancel pending status for a long time.

Article: 100023121
Last Published: 2025-06-02
Ratings: 1 4
Product(s): Backup Exec

Problem

Backup job may get stuck in cancel pending status for a long time.

Cause

Backup job cancellation may take some time or get stuck if a dependent process is not responding 

The below are possible reasons for the delay in job cancellation -

  • 3rd Party process/program/application not responding, which in turn causes delay in backup exec to process job termination.
  • The backup process was stuck due to unknown reasons and in which case, it is adviced to contact technical support to get the issue investigated.

 

Solution
 

Upgrade to the latest available Backup Exec version. Update the remote agents as well.

If job cancellations still get stuck, open a technical support case to investigate the problem.


WARNING

  • Job needs to be canceled manually.
  • This method will cancel ALL jobs that are currently running.


STEPS TO MANUALLY CANCEL STUCK JOBs :

Note: In a CAS MBES setup, ensure to restart BE services on the server where the job is actually running.

1. Launch servicesmgr.exe from BE Install Path.

2. Click on "Restart all services". Backup Exec Job Engine may take time to stop , so this process can be ended from the task manager.
Note: If job cancellation gets stuck on a particular remote server backup, then the remote agent on that remote server can be restarted or beremote.exe process on that remote server can be ended and then the job should get canceled. If the job is still stuck on cancel pending then continue with step 3.

3. Open "Windows Task Manager" and click on the "Details" tab.

4. Enable "Show Processes from all users".

5. Click on the "Name" column to sort alphabetically.

6. Locate and highlight the following processes.

  • Pvlsvr.exe (Backup Exec device and media service).
  • Bengine.exe (Backup Exec job engine service).
  • Beremote.exe (Backup Exec Remote Agent for Windows Server service).

7. Right Click on the above services in order and click on "End Process Tree" to terminate this process.

8. Close the task manager and return to the BE services manager.

9. After all the BE services are stopped, start all BE services from servicesmgr.exe

After all BE services are started, open Backup Exec console. There should not be an active job unless the same job gets auto triggered due to the error handling rules and, in which case, cancel it quickly. 
 

 

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