Backup Exec installation fails with "Failed to install SQL Express BKUPEXEC instance error 2"

Article: 100019359
Last Published: 2023-10-30
Ratings: 0 1
Product(s): Backup Exec

Problem

Error "Failed to install SQL Express BKUPEXEC instance error 2" appears while installing Backup Exec.

Error Message

"Failed to install SQL Express BKUPEXEC instance error 2"

Backup Exec installation fails while installing SQL Express instance for Backup Exec with the above mentioned error message. Backup Exec installation log (bkupinst.htm in the location C:\Document and Setting\All Users\Application Data\Symantec\Backup Exec\Logs) shows the following information:
 
 V-225-27: Cannot connect to Microsoft SQL Server <Server_Name). On the remote SQL Server, verify that: - Remote client connections are allowed. By default, SQL Server 2005 Express, Evaluation, or Developer editions allow local client connections only. For more information, refer to http://msdn2.microsoft.com/en-us/library/ms178763.aspx. - The user who is currently logged on this system is a member of the Administrators group on SQL Server PROJECT. - If SQL instance is behind a firewall, review the Backup Exec Administrator's Guide for steps on how to enable connections to a SQL instance behind a firewall.

 

Cause

This issue is encountered if AppData value is not copied correctly (or is missing) from HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\AppData to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\AppData when a user is created on a system.

 

Solution

 
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
 
1. To resolve this issue, ensure that the Registry Key "AppData" is present in the location HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\AppData.
 
2. If the above mentioned key is not present in both the locations, then create the Expandable String Value " AppData" with value %USERPROFILE%\Application Data
 

 

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