Windows Update History disappears after restoring a system using Veritas System Recovery

Article: 100009640
Last Published: 2018-03-05
Ratings: 0 0
Product(s): System Recovery

Problem

After restoring a system from the Veritas System Recovery Disk, the Windows View Update History is empty.

Cause

Because Veritas System Recovery (VSR) uses the Microsoft Volume Shadow Copy Services (VSS) to take a snapshot of the system so that it may be backed up at a point-in-time, this is expected behavior and it is working as designed.

For a more detailed explanation, please refer to the following Microsoft article about excluding files from VSS snapshots:
http://msdn.microsoft.com/en-us/library/windows/desktop/aa819132(v=vs.85).aspx

“After a file is added to the appropriate registry key value, it is deleted from the shadow copy during creation by the shadow copy optimization writer on a best-effort basis”. 

During VSR backups from within the Windows operating system, the Microsoft VSS framework snapshots the respective volumes.  As per the FilesNotToSnapshop registry key mentioned in the above article, this VSS writer excludes all files and folders listed in this registry key from the snapshot.  By default, Microsoft includes an entry in this registry key for the Windows Updates files and so VSS excludes them from the snapsho and they are therefore excluded from the VSR backup.

Solution

Because this is working as designed by Microsoft, there are no plans to address this issue. As a workaround, click the Installed Updates link in the Windows Update window. This will display all Microsoft updates currently on the system. (Please note that this does not have an impact when running Windows Update, which will recognize any installed updates and won't attempt to reinstall them.)


References

Etrack : 3218463

Was this content helpful?